summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2024-01-02 17:40:49 -0600
committerWilliam Hubbs <williamh@gentoo.org>2024-01-02 17:44:27 -0600
commitf147f8db36fc46f003868b7234197d32612ae391 (patch)
tree840c9c7fe3a025b65a6e36236515927155bf3098 /sys-cluster
parentdev-util/gitlab-runner: add 16.7.0 (diff)
downloadgentoo-f147f8db36fc46f003868b7234197d32612ae391.tar.gz
gentoo-f147f8db36fc46f003868b7234197d32612ae391.tar.bz2
gentoo-f147f8db36fc46f003868b7234197d32612ae391.zip
sys-cluster/kube-controller-manager: build with host version of go
Closes: https://bugs.gentoo.org/921216 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/kube-controller-manager/kube-controller-manager-1.28.5.ebuild3
-rw-r--r--sys-cluster/kube-controller-manager/z41
2 files changed, 43 insertions, 1 deletions
diff --git a/sys-cluster/kube-controller-manager/kube-controller-manager-1.28.5.ebuild b/sys-cluster/kube-controller-manager/kube-controller-manager-1.28.5.ebuild
index 202fbcc3d246..33452d9e0af1 100644
--- a/sys-cluster/kube-controller-manager/kube-controller-manager-1.28.5.ebuild
+++ b/sys-cluster/kube-controller-manager/kube-controller-manager-1.28.5.ebuild
@@ -24,7 +24,8 @@ S="${WORKDIR}/kubernetes-${PV}"
src_compile() {
CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')" \
- emake -j1 GOFLAGS=-v GOLDFLAGS="" LDFLAGS="" WHAT=cmd/${PN}
+ emake -j1 GOFLAGS=-v GOLDFLAGS="" LDFLAGS="" FORCE_HOST_GO=yes \
+ WHAT=cmd/${PN}
}
src_install() {
diff --git a/sys-cluster/kube-controller-manager/z b/sys-cluster/kube-controller-manager/z
new file mode 100644
index 000000000000..fae308ba2955
--- /dev/null
+++ b/sys-cluster/kube-controller-manager/z
@@ -0,0 +1,41 @@
+>>> Existing ${T}/environment for 'kube-controller-manager-1.28.5' will be
+>>> sourced. Run 'clean' to start with a fresh environment.
+>>> Checking kubernetes-1.28.5.tar.gz's mtime...
+>>> WORKDIR is up-to-date, keeping...
+Appending /home/william/repos/git.gentoo.org/repo/gentoo to PORTDIR_OVERLAY...
+>>> It appears that 'pretend' has already executed for 'kube-controller-manager-1.28.5'; skipping.
+>>> Remove '/var/tmp/portage/sys-cluster/kube-controller-manager-1.28.5/.pretended' to force pretend.
+>>> It appears that 'setup' has already executed for 'kube-controller-manager-1.28.5'; skipping.
+>>> Remove '/var/tmp/portage/sys-cluster/kube-controller-manager-1.28.5/.setuped' to force setup.
+>>> It appears that 'unpack' has already executed for 'kube-controller-manager-1.28.5'; skipping.
+>>> Remove '/var/tmp/portage/sys-cluster/kube-controller-manager-1.28.5/.unpacked' to force unpack.
+>>> It appears that 'prepare' has already executed for 'kube-controller-manager-1.28.5'; skipping.
+>>> Remove '/var/tmp/portage/sys-cluster/kube-controller-manager-1.28.5/.prepared' to force prepare.
+>>> It appears that 'configure' has already executed for 'kube-controller-manager-1.28.5'; skipping.
+>>> Remove '/var/tmp/portage/sys-cluster/kube-controller-manager-1.28.5/.configured' to force configure.
+>>> Compiling source in /var/tmp/portage/sys-cluster/kube-controller-manager-1.28.5/work/kubernetes-1.28.5 ...
+make -j9 -j1 GOFLAGS=-v GOLDFLAGS= LDFLAGS= WHAT=cmd/kube-controller-manager
+I don't have any idea what to do with '1.20.12'.
+ (using download type 'auto')
++++ [0102 17:24:38] Building go targets for linux/amd64
+ k8s.io/kubernetes/cmd/kube-controller-manager (static)
+go: downloading go1.20.12 (linux/amd64)
+go: download go1.20.12 for linux/amd64: toolchain not available
+!!! [0102 17:24:38] Call tree:
+!!! [0102 17:24:38] 1: /var/tmp/portage/sys-cluster/kube-controller-manager-1.28.5/work/kubernetes-1.28.5/hack/lib/golang.sh:787 kube::golang::build_some_binaries(...)
+!!! [0102 17:24:38] 2: /var/tmp/portage/sys-cluster/kube-controller-manager-1.28.5/work/kubernetes-1.28.5/hack/lib/golang.sh:957 kube::golang::build_binaries_for_platform(...)
+!!! [0102 17:24:38] 3: hack/make-rules/build.sh:27 kube::golang::build_binaries(...)
+!!! [0102 17:24:38] Call tree:
+!!! [0102 17:24:38] 1: hack/make-rules/build.sh:27 kube::golang::build_binaries(...)
+!!! [0102 17:24:38] Call tree:
+!!! [0102 17:24:38] 1: hack/make-rules/build.sh:27 kube::golang::build_binaries(...)
+make: *** [Makefile:92: all] Error 1
+ * ERROR: sys-cluster/kube-controller-manager-1.28.5::gentoo failed (compile phase):
+ * emake failed
+ *
+ * If you need support, post the output of `emerge --info '=sys-cluster/kube-controller-manager-1.28.5::gentoo'`,
+ * the complete build log and the output of `emerge -pqv '=sys-cluster/kube-controller-manager-1.28.5::gentoo'`.
+ * The complete build log is located at '/var/tmp/portage/sys-cluster/kube-controller-manager-1.28.5/temp/build.log'.
+ * The ebuild environment file is located at '/var/tmp/portage/sys-cluster/kube-controller-manager-1.28.5/temp/environment'.
+ * Working directory: '/var/tmp/portage/sys-cluster/kube-controller-manager-1.28.5/work/kubernetes-1.28.5'
+ * S: '/var/tmp/portage/sys-cluster/kube-controller-manager-1.28.5/work/kubernetes-1.28.5'