summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-12-02 09:28:06 +0100
committerMichał Górny <mgorny@gentoo.org>2018-12-02 09:38:15 +0100
commit45603e83dea716f18e4fe443cdeda19f05a4016d (patch)
treeed02ca1c0b68440fab4ecad3a3641890aa01b37e /sys-devel/distcc
parentsys-devel/distcc: Use lib for libdir consistently (diff)
downloadgentoo-45603e83dea716f18e4fe443cdeda19f05a4016d.tar.gz
gentoo-45603e83dea716f18e4fe443cdeda19f05a4016d.tar.bz2
gentoo-45603e83dea716f18e4fe443cdeda19f05a4016d.zip
sys-devel/distcc: Improve src_configure readability
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/distcc')
-rw-r--r--sys-devel/distcc/distcc-3.3.ebuild19
1 files changed, 10 insertions, 9 deletions
diff --git a/sys-devel/distcc/distcc-3.3.ebuild b/sys-devel/distcc/distcc-3.3.ebuild
index 2a717b289136..aa78ecf5d2b8 100644
--- a/sys-devel/distcc/distcc-3.3.ebuild
+++ b/sys-devel/distcc/distcc-3.3.ebuild
@@ -75,17 +75,18 @@ src_prepare() {
}
src_configure() {
- local myconf="--disable-Werror"
+ local myconf=(
+ --disable-Werror
+ $(use_with gtk)
+ $(use_with gnome)
+ $(use_with gssapi auth)
+ $(use_with zeroconf avahi)
+ )
# --disable-rfc2553 b0rked, bug #254176
- use ipv6 && myconf="${myconf} --enable-rfc2553"
-
- econf \
- $(use_with gtk) \
- $(use_with gnome) \
- $(use_with gssapi auth) \
- $(use_with zeroconf avahi) \
- ${myconf}
+ use ipv6 && myconf+=(--enable-rfc2553)
+
+ econf "${myconf[@]}"
}
src_install() {