summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-07-05 21:48:05 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2021-07-05 22:00:53 +0100
commit203a076d355efe6a2fc22a6c828fc5656bd40405 (patch)
treef24ed30f66a72cc3b7a61da165302cbec9a41453 /sys-devel/gcc/gcc-11.1.0-r2.ebuild
parentprofiles/selinux: unbreak deps: mask gnome packages needing systemd (diff)
downloadgentoo-203a076d355efe6a2fc22a6c828fc5656bd40405.tar.gz
gentoo-203a076d355efe6a2fc22a6c828fc5656bd40405.tar.bz2
gentoo-203a076d355efe6a2fc22a6c828fc5656bd40405.zip
sys-devel/gcc: 11.1.0: cut 3 patchset
Single new change: + 32_all_remove-cyclades.patch: fix build failure against linux-headers-5.13 Bug: https://gcc.gnu.org/PR100379 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-devel/gcc/gcc-11.1.0-r2.ebuild')
-rw-r--r--sys-devel/gcc/gcc-11.1.0-r2.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/sys-devel/gcc/gcc-11.1.0-r2.ebuild b/sys-devel/gcc/gcc-11.1.0-r2.ebuild
new file mode 100644
index 000000000000..b0cbe26c743d
--- /dev/null
+++ b/sys-devel/gcc/gcc-11.1.0-r2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PATCH_VER="3"
+
+inherit toolchain
+
+#KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND=""
+BDEPEND="${CATEGORY}/binutils"
+
+src_prepare() {
+ if has_version '>=sys-libs/glibc-2.32-r1'; then
+ rm -v "${WORKDIR}/patch/21_all_disable-riscv32-ABIs.patch" || die
+ fi
+
+ toolchain_src_prepare
+}