summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-07-05 21:51:39 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2021-07-05 22:00:55 +0100
commit1b4cedaf74d7aa800f95467df2e482870004d518 (patch)
treec1fec11b0574674f70c29a5ce51a117ce630c17f /sys-devel/gcc/gcc-8.5.0-r1.ebuild
parentsys-devel/gcc: 10.3.0: cut 3 patchset (diff)
downloadgentoo-1b4cedaf74d7aa800f95467df2e482870004d518.tar.gz
gentoo-1b4cedaf74d7aa800f95467df2e482870004d518.tar.bz2
gentoo-1b4cedaf74d7aa800f95467df2e482870004d518.zip
sys-devel/gcc: 8.5.0: cut 2 patchset
Single new change: + 30_all_remove-cyclades.patch: fix build failure against linux-headers-5.13 Bug: https://gcc.gnu.org/PR100379 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-devel/gcc/gcc-8.5.0-r1.ebuild')
-rw-r--r--sys-devel/gcc/gcc-8.5.0-r1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/sys-devel/gcc/gcc-8.5.0-r1.ebuild b/sys-devel/gcc/gcc-8.5.0-r1.ebuild
new file mode 100644
index 000000000000..5141e9aa3b31
--- /dev/null
+++ b/sys-devel/gcc/gcc-8.5.0-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PATCH_VER="2"
+
+inherit toolchain
+
+#KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ elibc_glibc? ( >=sys-libs/glibc-2.13 )
+ >=${CATEGORY}/binutils-2.20"
+
+if [[ ${CATEGORY} != cross-* ]] ; then
+ PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.13 )"
+fi