summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-06 20:54:31 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-06 22:11:04 +0200
commit189ba493932c2aa1ce48f78a0c19258cf745ae80 (patch)
tree686817b494f014eaf4f7c7abdffc97624709800a /sys-devel
parentdev-python/nbclient: Bump to 0.7.0 (diff)
downloadgentoo-189ba493932c2aa1ce48f78a0c19258cf745ae80.tar.gz
gentoo-189ba493932c2aa1ce48f78a0c19258cf745ae80.tar.bz2
gentoo-189ba493932c2aa1ce48f78a0c19258cf745ae80.zip
sys-devel/llvm: Enable zstd in 16.0.0.9999
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/llvm/llvm-16.0.0.9999.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/sys-devel/llvm/llvm-16.0.0.9999.ebuild b/sys-devel/llvm/llvm-16.0.0.9999.ebuild
index 9171387473ba..b306d267303c 100644
--- a/sys-devel/llvm/llvm-16.0.0.9999.ebuild
+++ b/sys-devel/llvm/llvm-16.0.0.9999.ebuild
@@ -4,8 +4,8 @@
EAPI=8
PYTHON_COMPAT=( python3_{8..11} )
-inherit cmake llvm.org multilib-minimal pax-utils python-any-r1 \
- toolchain-funcs
+inherit cmake llvm.org multilib multilib-minimal pax-utils \
+ python-any-r1 toolchain-funcs
DESCRIPTION="Low Level Virtual Machine"
HOMEPAGE="https://llvm.org/"
@@ -19,7 +19,10 @@ HOMEPAGE="https://llvm.org/"
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA BSD public-domain rc"
SLOT="$(ver_cut 1)"
KEYWORDS=""
-IUSE="+binutils-plugin debug doc exegesis libedit +libffi ncurses test xar xml z3"
+IUSE="
+ +binutils-plugin debug doc exegesis libedit +libffi ncurses test xar
+ xml z3 zstd
+"
RESTRICT="!test? ( test )"
RDEPEND="
@@ -32,6 +35,7 @@ RDEPEND="
xar? ( app-arch/xar )
xml? ( dev-libs/libxml2:2=[${MULTILIB_USEDEP}] )
z3? ( >=sci-mathematics/z3-4.7.1:0=[${MULTILIB_USEDEP}] )
+ zstd? ( app-arch/zstd:=[${MULTILIB_USEDEP}] )
"
DEPEND="
${RDEPEND}
@@ -366,6 +370,7 @@ multilib_src_configure() {
-DLLVM_ENABLE_EH=ON
-DLLVM_ENABLE_RTTI=ON
-DLLVM_ENABLE_Z3_SOLVER=$(usex z3)
+ -DLLVM_ENABLE_ZSTD=$(usex zstd)
-DLLVM_HOST_TRIPLE="${CHOST}"