summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-09-03 16:46:49 +0200
committerMichał Górny <mgorny@gentoo.org>2016-09-03 19:35:30 +0200
commit1cba74ccbbac94faacfe3ca83eae0b6516a5e54c (patch)
treee476ca5e9cfd907a1a93208e96fad387d4a4b67c /sys-devel
parentdev-python/natsort: depend on virtual/python-pathlib (diff)
downloadgentoo-1cba74ccbbac94faacfe3ca83eae0b6516a5e54c.tar.gz
gentoo-1cba74ccbbac94faacfe3ca83eae0b6516a5e54c.tar.bz2
gentoo-1cba74ccbbac94faacfe3ca83eae0b6516a5e54c.zip
sys-devel/llvm: Readd WX stack fix to 3.9.0
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/llvm/llvm-3.9.0.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/sys-devel/llvm/llvm-3.9.0.ebuild b/sys-devel/llvm/llvm-3.9.0.ebuild
index ed79ebb12ee1..3752c6d98e94 100644
--- a/sys-devel/llvm/llvm-3.9.0.ebuild
+++ b/sys-devel/llvm/llvm-3.9.0.ebuild
@@ -202,6 +202,15 @@ src_prepare() {
# Fix git-clang-format shebang, bug #562688
python_fix_shebang tools/clang/tools/clang-format/git-clang-format
+
+ pushd projects/compiler-rt >/dev/null || die
+
+ # Fix WX sections, bug #421527
+ find lib/builtins -type f -name '*.S' -exec sed \
+ -e '$a\\n#if defined(__linux__) && defined(__ELF__)\n.section .note.GNU-stack,"",%progbits\n#endif' \
+ -i {} + || die
+
+ popd >/dev/null || die
fi
if use lldb; then