summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArsen Arsenović <arsen@gentoo.org>2023-12-23 20:04:43 +0100
committerArsen Arsenović <arsen@gentoo.org>2023-12-23 21:02:49 +0100
commitb26e2ee61d7b8db23cf1849c7fa5e7e5d714c420 (patch)
tree5ad25ba500555feb98031e061234a8412e2c512c /sys-devel
parentmedia-libs/openjpeg: Stabilize 2.5.0-r6 hppa, #920219 (diff)
downloadgentoo-b26e2ee61d7b8db23cf1849c7fa5e7e5d714c420.tar.gz
gentoo-b26e2ee61d7b8db23cf1849c7fa5e7e5d714c420.tar.bz2
gentoo-b26e2ee61d7b8db23cf1849c7fa5e7e5d714c420.zip
sys-devel/autoconf-vanilla: add 2.72
Signed-off-by: Arsen Arsenović <arsen@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/autoconf-vanilla/Manifest2
-rw-r--r--sys-devel/autoconf-vanilla/autoconf-vanilla-2.72.ebuild99
-rw-r--r--sys-devel/autoconf-vanilla/files/autoconf-2.72-conflicts.patch (renamed from sys-devel/autoconf-vanilla/files/autoconf-2.72c-conflicts.patch)31
3 files changed, 117 insertions, 15 deletions
diff --git a/sys-devel/autoconf-vanilla/Manifest b/sys-devel/autoconf-vanilla/Manifest
index e7e8a8d234f7..6205dc360ab0 100644
--- a/sys-devel/autoconf-vanilla/Manifest
+++ b/sys-devel/autoconf-vanilla/Manifest
@@ -2,3 +2,5 @@ DIST autoconf-2.13.tar.gz 443844 BLAKE2B ade10f9d4a0b1a0e8b752eee817cfe100d77b07
DIST autoconf-2.69-runstatedir_patches.tar.xz 257096 BLAKE2B ae765e0ca7fe8261117f6f6b75611c232fc3d4016c22c86346afa72f2b7e6c3b7ccc1f9dfe134b2443f8bde6d578b503d79cf88472f76ce75b6c2e843ef55b8e SHA512 55f93299fe5243151f6bb782986a7935270f06d5065929f4d365a37aba05703e3ce66ecf7981d30413db50ee6b4f77d81d10a71b539c8a366c5c5a156c5443da
DIST autoconf-2.69.tar.xz 1214744 BLAKE2B 71d33d72a06e9a05fbed0eda73bc9d8a3805c7c90bf082959862f93f3c5f01192114176e84d84ecb58fa99512eafbc0ab21ad1407be18c8c63bb3dc1117c482d SHA512 995d3e5a8eb1eb37e2b7fae53c6ec7a9b4df997286b7d643344818f94636756b1bf5ff5ea9155e755cb9461149a853dfbf2886fc6bd7132e5afa9c168e306e9b
DIST autoconf-2.71.tar.xz 1292296 BLAKE2B 7fd4b98b4cfff10720e8da6ee91045637991643b50fcb3e47a0ecfcc01600f7b7b36fd1c0a5f08b68a418f1bdbd8d5a98de1008157595dd37cc3a31facb61416 SHA512 73d32b4adcbe24e3bafa9f43f59ed3b6efbd3de0f194e5ec90375f35da1199c583f5d3e89139b7edbad35171403709270e339ffa56a2ecb9b3123e9285021ff0
+DIST autoconf-2.72.tar.xz 1389680 BLAKE2B 01caeced9e53d8bd39fb0cf4929322f0d463971b0a96368aa55892026897a9e98c2ca84a77db1b3c6c4483aea54b96da16a7bc00b7ac15e23c6b0471438012db SHA512 c4e9fbd858666d3e5c3b4fe7f89aa3e8e3a0a00dc7e166f8147d937d911b77ba3ac6a016f9d223ccdd830bc8960b3e60397c0607cc6a1fd2c50c7492839ddd17
+DIST autoconf-2.72.tar.xz.sig 833 BLAKE2B cc33101c5d2bd28f233e54a2843d3c81dc9729238b0900a8f23ef17b982aa0e0194892c07b1365246b6c9c0ea74becd288ae581ee34d593131b83538c69a6204 SHA512 7a0d350b23cf47c45811ae35928a4fec67ce1f3adb1965904fe6d9a0fad68139df4902662bcf4731a2f809381cae0b265a8f1f57d0a9a39777250a97a3c481d9
diff --git a/sys-devel/autoconf-vanilla/autoconf-vanilla-2.72.ebuild b/sys-devel/autoconf-vanilla/autoconf-vanilla-2.72.ebuild
new file mode 100644
index 000000000000..f1a04c4b3fb3
--- /dev/null
+++ b/sys-devel/autoconf-vanilla/autoconf-vanilla-2.72.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://git.savannah.gnu.org/git/autoconf.git"
+ inherit git-r3
+else
+ MY_PN=${PN/-vanilla}
+ # For _beta handling replace with real version number
+ MY_PV="${PV}"
+ MY_P="${MY_PN}-${MY_PV}"
+ #PATCH_TARBALL_NAME="${MY_PN}-2.70-patches-01"
+
+ VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/zackweinberg.asc
+ inherit verify-sig
+
+ SRC_URI="
+ mirror://gnu/${MY_PN}/${MY_P}.tar.xz
+ https://alpha.gnu.org/pub/gnu/${MY_PN}/${MY_P}.tar.xz
+ https://meyering.net/ac/${MY_P}.tar.xz
+ verify-sig? ( mirror://gnu/${PN}/${MY_P}.tar.xz.sig )
+ "
+ S="${WORKDIR}"/${MY_P}
+
+ if [[ ${PV} != *_beta* ]] && ! [[ $(ver_cut 3) =~ [a-z] ]] ; then
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+ fi
+
+ BDEPEND="verify-sig? ( sec-keys/openpgp-keys-zackweinberg )"
+fi
+
+inherit toolchain-autoconf
+
+DESCRIPTION="Used to create autoconfiguration files"
+HOMEPAGE="https://www.gnu.org/software/autoconf/autoconf.html"
+
+LICENSE="GPL-3+"
+SLOT="$(ver_cut 1-2)"
+IUSE="emacs"
+
+BDEPEND+="
+ >=dev-lang/perl-5.10
+ >=sys-devel/m4-1.4.16
+"
+RDEPEND="
+ ${BDEPEND}
+ >=sys-devel/autoconf-wrapper-15
+ sys-devel/gnuconfig
+ !~sys-devel/${P}:2.5
+"
+[[ ${PV} == 9999 ]] && BDEPEND+=" >=sys-apps/texinfo-4.3"
+PDEPEND="emacs? ( app-emacs/autoconf-mode )"
+
+PATCHES=(
+ "${FILESDIR}"/"${MY_P}"-conflicts.patch
+)
+
+TC_AUTOCONF_ENVPREFIX=07
+
+src_prepare() {
+ if [[ ${PV} == *9999 ]] ; then
+ # Avoid the "dirty" suffix in the git version by generating it
+ # before we run later stages which might modify source files.
+ local ver=$(./build-aux/git-version-gen .tarball-version)
+ echo "${ver}" > .tarball-version || die
+
+ autoreconf -f -i || die
+ fi
+
+ # usr/bin/libtool is provided by binutils-apple, need gnu libtool
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ PATCHES+=( "${FILESDIR}"/${MY_PN}-2.71-darwin.patch )
+ fi
+
+ # Save timestamp to avoid later makeinfo call
+ touch -r doc/{,old_}autoconf.texi || die
+
+ toolchain-autoconf_src_prepare
+
+ # Restore timestamp to avoid makeinfo call
+ # We already have an up to date autoconf.info page at this point.
+ touch -r doc/{old_,}autoconf.texi || die
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ toolchain-autoconf_src_install
+
+ local f
+ for f in config.{guess,sub} ; do
+ ln -fs ../../gnuconfig/${f} \
+ "${ED}"/usr/share/autoconf-*/build-aux/${f} || die
+ done
+}
diff --git a/sys-devel/autoconf-vanilla/files/autoconf-2.72c-conflicts.patch b/sys-devel/autoconf-vanilla/files/autoconf-2.72-conflicts.patch
index 2ff6418a3a34..b90864eacecb 100644
--- a/sys-devel/autoconf-vanilla/files/autoconf-2.72c-conflicts.patch
+++ b/sys-devel/autoconf-vanilla/files/autoconf-2.72-conflicts.patch
@@ -1,15 +1,15 @@
-From 8eee2e2b910c6c3d837a4708d4d5d3d80afd8ef9 Mon Sep 17 00:00:00 2001
-From: Arsen Arsenović <arsen@gentoo.org>
-Date: Sat, 4 Nov 2023 00:20:05 +0100
+From ca78a8d7d653ac8199fa0346a814289ed7aef960 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Arsen=20Arsenovi=C4=87?= <arsen@gentoo.org>
+Date: Sat, 4 Nov 2023 00:32:48 +0100
Subject: [PATCH] Append '-vanilla' to pkgdatadir
---
Makefile.am | 3 +++
- Makefile.in | 3 ++-
- 2 files changed, 5 insertions(+), 1 deletion(-)
+ Makefile.in | 4 +++-
+ 2 files changed, 6 insertions(+), 1 deletion(-)
diff --git a/Makefile.am b/Makefile.am
-index 28bb494..dfc8932 100644
+index 1db714b..cb0650a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -18,6 +18,9 @@
@@ -23,26 +23,27 @@ index 28bb494..dfc8932 100644
## makefile fragments.
ETAGS_ARGS =
diff --git a/Makefile.in b/Makefile.in
-index 2cde4d0..cf17242 100644
+index e5b3da5..04a3732 100644
--- a/Makefile.in
+++ b/Makefile.in
-@@ -197,7 +197,6 @@ am__make_dryrun = (target_option=n; $(am__make_running_with_option))
+@@ -195,7 +195,6 @@ am__make_running_with_option = \
+ test $$has_opt = yes
+ am__make_dryrun = (target_option=n; $(am__make_running_with_option))
am__make_keepgoing = (target_option=k; $(am__make_running_with_option))
- am__rm_f = rm -f $(am__rm_f_notfound)
- am__rm_rf = rm -rf $(am__rm_f_notfound)
-pkgdatadir = $(datadir)/@PACKAGE@-@VERSION@
pkgincludedir = $(includedir)/@PACKAGE@
pkglibdir = $(libdir)/@PACKAGE@
pkglibexecdir = $(libexecdir)/@PACKAGE@
-@@ -401,6 +400,8 @@ am__distuninstallcheck_listfiles = $(distuninstallcheck_listfiles) \
- distcleancheck_listfiles = \
- find . \( -type f -a \! \
- \( -name .nfs* -o -name .smb* -o -name .__afs* \) \) -print
+@@ -398,6 +397,9 @@ distuninstallcheck_listfiles = find . -type f -print
+ am__distuninstallcheck_listfiles = $(distuninstallcheck_listfiles) \
+ | sed 's|^\./|$(prefix)/|' | grep -v '$(infodir)/dir$$'
+ distcleancheck_listfiles = find . -type f -print
++
+# Work around file conflicts against sys-devel/autoconf -- Arsen
+pkgdatadir = $(datadir)/@PACKAGE@-vanilla-@VERSION@
ACLOCAL = @ACLOCAL@
AMTAR = @AMTAR@
AM_DEFAULT_VERBOSITY = @AM_DEFAULT_VERBOSITY@
--
-2.42.0
+2.43.0