summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-12 15:56:51 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-12 20:26:46 +0200
commitdff2cca66a0176a6ea404eda3720e500e6a050e7 (patch)
treeb097b0c277277474ecff3cb6efeb3965d8995b48 /sys-devel
parentsys-libs/libomp: Add 17.0.0_pre20230512 snapshot (diff)
downloadgentoo-dff2cca66a0176a6ea404eda3720e500e6a050e7.tar.gz
gentoo-dff2cca66a0176a6ea404eda3720e500e6a050e7.tar.bz2
gentoo-dff2cca66a0176a6ea404eda3720e500e6a050e7.zip
sys-devel/clang-runtime: Add 17.0.0_pre20230512 snapshot
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang-runtime/clang-runtime-17.0.0_pre20230512.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-17.0.0_pre20230512.ebuild b/sys-devel/clang-runtime/clang-runtime-17.0.0_pre20230512.ebuild
new file mode 100644
index 000000000000..67b42357665e
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-17.0.0_pre20230512.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build toolchain-funcs
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+
+LICENSE="metapackage"
+SLOT="${PV%%.*}"
+KEYWORDS=""
+IUSE="+compiler-rt libcxx openmp +sanitize"
+REQUIRED_USE="sanitize? ( compiler-rt )"
+PROPERTIES="live"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ sanitize? (
+ ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )
+"
+
+pkg_pretend() {
+ if tc-is-clang; then
+ ewarn "You seem to be using clang as a system compiler. As of clang-16,"
+ ewarn "upstream has turned a few warnings that commonly occur during"
+ ewarn "configure script runs into errors by default. This causes some"
+ ewarn "configure tests to start failing, sometimes resulting in silent"
+ ewarn "breakage, missing functionality or runtime misbehavior. It is"
+ ewarn "not yet clear whether the change will remain or be reverted."
+ ewarn
+ ewarn "For more information, please see:"
+ ewarn "https://discourse.llvm.org/t/configure-script-breakage-with-the-new-werror-implicit-function-declaration/65213"
+ fi
+}