summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2023-04-11 22:02:07 +0300
committerViorel Munteanu <ceamac@gentoo.org>2023-04-11 22:41:49 +0300
commitdb7c461232efbeef3a381f204d27b9e9defad807 (patch)
tree9bca3e5cee4cb77ef82bf48b1fb91eadd609d715 /sys-fs/f2fs-tools
parentdev-python/accessible-pygments: Stabilize 0.0.4 hppa, #904177 (diff)
downloadgentoo-db7c461232efbeef3a381f204d27b9e9defad807.tar.gz
gentoo-db7c461232efbeef3a381f204d27b9e9defad807.tar.bz2
gentoo-db7c461232efbeef3a381f204d27b9e9defad807.zip
sys-fs/f2fs-tools: add 1.16.0
Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'sys-fs/f2fs-tools')
-rw-r--r--sys-fs/f2fs-tools/Manifest1
-rw-r--r--sys-fs/f2fs-tools/f2fs-tools-1.16.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/sys-fs/f2fs-tools/Manifest b/sys-fs/f2fs-tools/Manifest
index 21258a7ca4b6..7093187d4ebf 100644
--- a/sys-fs/f2fs-tools/Manifest
+++ b/sys-fs/f2fs-tools/Manifest
@@ -1 +1,2 @@
DIST f2fs-tools-1.15.0.tar.gz 387663 BLAKE2B 1e55f87c839cee6431d9a83e9786201e9b6b872be27c8b92854b30b0fd1c651a9b7235ce93e70c530bfa7a4e9f4dfd309c72702b3338a4aa96e365b29424fb1d SHA512 61e40f16296091b55cec2dbdc6306af6abc2d3f854f39ef03a741b7f6f47348f915498375789f017f8da27fa7d27c79c905dd047693518adde503ea7ebf89387
+DIST f2fs-tools-1.16.0.tar.gz 265507 BLAKE2B a4fb94ff879198652a2922a0101b7e34aad156c3536e5a20c1cb2e36a6a734d92d3f97b2570eb702d029ef1d6c03d6123113fc1aa5658ba979401e0691b7b447 SHA512 ea198cebf7c5bb0c42c9b53bc80484495c403b1ed1354eb7cb7b4f63ed9a5c81653a76eaf1bc35067171fa5fd99b1564178c5440c21b6b025f4e83b9def82680
diff --git a/sys-fs/f2fs-tools/f2fs-tools-1.16.0.ebuild b/sys-fs/f2fs-tools/f2fs-tools-1.16.0.ebuild
new file mode 100644
index 000000000000..3224cc7ec9ff
--- /dev/null
+++ b/sys-fs/f2fs-tools/f2fs-tools-1.16.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Tools for Flash-Friendly File System (F2FS)"
+HOMEPAGE="https://git.kernel.org/pub/scm/linux/kernel/git/jaegeuk/f2fs-tools.git/about/"
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.kernel.org/pub/scm/linux/kernel/git/jaegeuk/${PN}.git"
+ EGIT_BRANCH="dev"
+else
+ SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/jaegeuk/${PN}.git/snapshot/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0/10"
+IUSE="selinux"
+
+RDEPEND="
+ app-arch/lz4:=
+ dev-libs/lzo:2
+ sys-apps/util-linux
+ selinux? ( sys-libs/libselinux )
+ elibc_musl? ( sys-libs/queue-standalone )
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ # This is required to install to /sbin, bug #481110
+ --bindir="${EPREFIX}"/sbin
+ $(use_with selinux)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name "*.la" -delete || die
+}