summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-12-29 23:01:24 +0100
committerConrad Kostecki <conikost@gentoo.org>2023-12-31 03:39:05 +0100
commitcc31650f4f4221ca8f921a8bec9e0945614ceccc (patch)
tree89019fa9a67b027d186d7712571d735deb3910ff /sys-fs
parentsys-apps/less: remove unused patch/file (diff)
downloadgentoo-cc31650f4f4221ca8f921a8bec9e0945614ceccc.tar.gz
gentoo-cc31650f4f4221ca8f921a8bec9e0945614ceccc.tar.bz2
gentoo-cc31650f4f4221ca8f921a8bec9e0945614ceccc.zip
sys-fs/mp3fs: fix LICENSE, fix bug #869656
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://bugs.gentoo.org/869656 Closes: https://github.com/gentoo/gentoo/pull/34552 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/mp3fs/mp3fs-1.1.1-r5.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-fs/mp3fs/mp3fs-1.1.1-r5.ebuild b/sys-fs/mp3fs/mp3fs-1.1.1-r5.ebuild
new file mode 100644
index 000000000000..f8a75766501d
--- /dev/null
+++ b/sys-fs/mp3fs/mp3fs-1.1.1-r5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Read-only FUSE filesystem which transcodes FLAC audio files to MP3 when read"
+HOMEPAGE="https://khenriks.github.io/mp3fs/"
+SRC_URI="https://github.com/khenriks/mp3fs/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+flac vorbis"
+
+REQUIRED_USE="|| ( flac vorbis )"
+RESTRICT="test"
+
+DEPEND="
+ media-libs/libid3tag:=
+ media-sound/lame
+ sys-fs/fuse:0=
+ flac? ( >=media-libs/flac-1.1.4:=[cxx] )
+ vorbis? ( >=media-libs/libvorbis-1.3.0 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ $(use_with flac) \
+ $(use_with vorbis)
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}