summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2024-08-25 06:52:06 -0400
committerMike Pagano <mpagano@gentoo.org>2024-08-25 06:52:06 -0400
commit8e1f348975b5a6449ba6b2ceb1a5f874235551ac (patch)
tree31f55b429a9c30c9448f398864e2b0417d4720e1 /sys-kernel
parentdev-util/pahole: Stabilize 1.27-r1 arm64, #938465 (diff)
downloadgentoo-8e1f348975b5a6449ba6b2ceb1a5f874235551ac.tar.gz
gentoo-8e1f348975b5a6449ba6b2ceb1a5f874235551ac.tar.bz2
gentoo-8e1f348975b5a6449ba6b2ceb1a5f874235551ac.zip
sys-kernel/git-sources: add 6.11_rc5
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-6.11_rc5.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index 74147c39f059..31dca5658a29 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -3,3 +3,4 @@ DIST patch-6.11-rc1.patch 84813682 BLAKE2B 6e0366cfcd85ad1d16bff987ae4cc68691685
DIST patch-6.11-rc2.patch 85196283 BLAKE2B 93b294cd980fdbb9b0c95d6ac9f104a6d80c9d4ea0dd5b3d42129161205cdd63e140f52a52c5b16b4d41aeb0f50fa49a565deabd92707baaeb4df01da06d6e0b SHA512 a4c26e7ff227d264cd76ef6b69aeaa451fd54bf24bca5d7f45e1964b11b6da69eb8bc9d226ca9c3383c41bf2d85739232eef2c0e27f83e16440183bfbdb659de
DIST patch-6.11-rc3.patch 85423245 BLAKE2B 01eb8f98e554337f199843071dff67407d3d90d1c6a8ef93f11709116555401a24b98c88747cdb6dd66f32fd0f88e8dc07f708d95826139f359b3aecbd8e2c40 SHA512 61d942a1bd70fd6b4fe99ee0797949a305e07e055db70f76d3691b0304ec04e3599115be4598bf9fd83fd53bcffd628eef643f07deb189c85b771937c5e6cb3c
DIST patch-6.11-rc4.patch 85940549 BLAKE2B 5d9fcd92de3f686d1b8c795b5eeec39959a11393bfbb756b0aca9f00080a5b75dccf4f7f0c9d9395b936a703ae96345a926a9d724b83de630d7eb6f6051ae4fa SHA512 7ee0ea6fa42c403057cd167452fa4d910c7625f9836c645a41e3c578f959a1eebd28103f859d4da0ef9c9c8a512e6f8001aae723e8c3fd2d56b5d60480fcc18c
+DIST patch-6.11-rc5.patch 86328047 BLAKE2B a436fed2fce9ac102fc402b6e2488683d81240a9f203a106b30cd5b3f33c887e5ef06e6e531527fb9f6b6eb90ae69e6fc3a62f7788e60a3c8f3cd94b85a827f6 SHA512 e96bb72c48dcc214d07c73babb42efa1f12499276fa03e6d3fef839e8e1a41430eb7c1d107caff64288f173ed8c970168e068427e5ca13c30857fe7db781eb91
diff --git a/sys-kernel/git-sources/git-sources-6.11_rc5.ebuild b/sys-kernel/git-sources/git-sources-6.11_rc5.ebuild
new file mode 100644
index 000000000000..c48bb8c7d15c
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-6.11_rc5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="6.10"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+K_NODRYRUN="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.6-r4"
+
+pkg_postinst() {
+ postinst_sources
+}