summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-07-24 10:21:45 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2021-07-24 10:21:59 +0100
commit41fa2e689f53efe62986696bf4324aca16bc874a (patch)
treed35b8809dae79e2c79f72f215d569168c1583017 /sys-libs/libstdc++-v3
parentdev-python/sure: Mark ALLARCHES (diff)
downloadgentoo-41fa2e689f53efe62986696bf4324aca16bc874a.tar.gz
gentoo-41fa2e689f53efe62986696bf4324aca16bc874a.tar.bz2
gentoo-41fa2e689f53efe62986696bf4324aca16bc874a.zip
sys-libs/libstdc++-v3: use user's AR and NM
Reported-by: Agostino Sarubbo Closes: https://bugs.gentoo.org/724726 Closes: https://bugs.gentoo.org/792987 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-libs/libstdc++-v3')
-rw-r--r--sys-libs/libstdc++-v3/libstdc++-v3-3.3.6-r3.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/sys-libs/libstdc++-v3/libstdc++-v3-3.3.6-r3.ebuild b/sys-libs/libstdc++-v3/libstdc++-v3-3.3.6-r3.ebuild
index 2e11d8135f0d..0bf6a4ade8c8 100644
--- a/sys-libs/libstdc++-v3/libstdc++-v3-3.3.6-r3.ebuild
+++ b/sys-libs/libstdc++-v3/libstdc++-v3-3.3.6-r3.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit epatch flag-o-matic libtool multilib
+inherit epatch flag-o-matic libtool multilib toolchain-funcs
PATCH_VER="1.10"
@@ -151,6 +151,8 @@ src_prepare() {
"${S}"/gcc/config/i386/t-linux64 \
|| die "sed failed!"
fi
+
+ tc-export AR CC RANLIB NM
}
src_configure() {
@@ -175,12 +177,17 @@ src_configure() {
}
src_compile() {
- emake -C "${WORKDIR}"/build all-target-libstdc++-v3
+ emake \
+ -C "${WORKDIR}"/build all-target-libstdc++-v3 \
+ AR="$(tc-getAR)" \
+ NM="$(tc-getNM)"
}
src_install() {
emake -j1 \
-C "${WORKDIR}"/build \
+ AR="$(tc-getAR)" \
+ NM="$(tc-getNM)" \
DESTDIR="${D}" \
install-target-libstdc++-v3