summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-21 10:23:00 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-21 10:23:20 +0200
commit759bab9622dc3c537341412a3b42a02242b1cefb (patch)
tree9c5dfe65dc94ae9f19ef1ce4ff190c6428b8a37b /sys-libs/llvm-libunwind
parentsys-libs/libcxx: Force matchling LLVM/Clang version (diff)
downloadgentoo-759bab9622dc3c537341412a3b42a02242b1cefb.tar.gz
gentoo-759bab9622dc3c537341412a3b42a02242b1cefb.tar.bz2
gentoo-759bab9622dc3c537341412a3b42a02242b1cefb.zip
sys-libs/llvm-libunwind: Force matchling LLVM/Clang version
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-libs/llvm-libunwind')
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-15.0.1.9999.ebuild15
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-15.0.1.ebuild15
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-16.0.0.9999.ebuild15
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-16.0.0_pre20220918.ebuild15
4 files changed, 36 insertions, 24 deletions
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-15.0.1.9999.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-15.0.1.9999.ebuild
index c682d12707f2..67d11a24dc77 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-15.0.1.9999.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-15.0.1.9999.ebuild
@@ -20,13 +20,13 @@ RESTRICT="!test? ( test )"
RDEPEND="
!sys-libs/libunwind
"
-# llvm-6 for new lit options
+LLVM_MAX_SLOT=${PV%%.*}
DEPEND="
- >=sys-devel/llvm-6
+ sys-devel/llvm:${LLVM_MAX_SLOT}
"
BDEPEND="
clang? (
- sys-devel/clang
+ sys-devel/clang:${LLVM_MAX_SLOT}
)
!test? (
${PYTHON_DEPS}
@@ -45,6 +45,11 @@ python_check_deps() {
python_has_version "dev-python/lit[${PYTHON_USEDEP}]"
}
+pkg_setup() {
+ llvm_pkg_setup
+ python-any-r1_pkg_setup
+}
+
multilib_src_configure() {
local use_compiler_rt=OFF
local libdir=$(get_libdir)
@@ -53,9 +58,7 @@ multilib_src_configure() {
# also separately bug #863917
filter-lto
- if use clang && ! tc-is-clang; then
- # Only do this conditionally to allow overriding with
- # e.g. CC=clang-13 in case of breakage
+ if use clang; then
local -x CC=${CHOST}-clang
local -x CXX=${CHOST}-clang++
strip-unsupported-flags
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-15.0.1.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-15.0.1.ebuild
index 266fb98a49d9..cf301e306fd9 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-15.0.1.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-15.0.1.ebuild
@@ -20,13 +20,13 @@ RESTRICT="!test? ( test )"
RDEPEND="
!sys-libs/libunwind
"
-# llvm-6 for new lit options
+LLVM_MAX_SLOT=${PV%%.*}
DEPEND="
- >=sys-devel/llvm-6
+ sys-devel/llvm:${LLVM_MAX_SLOT}
"
BDEPEND="
clang? (
- sys-devel/clang
+ sys-devel/clang:${LLVM_MAX_SLOT}
)
!test? (
${PYTHON_DEPS}
@@ -45,6 +45,11 @@ python_check_deps() {
python_has_version "dev-python/lit[${PYTHON_USEDEP}]"
}
+pkg_setup() {
+ llvm_pkg_setup
+ python-any-r1_pkg_setup
+}
+
multilib_src_configure() {
local use_compiler_rt=OFF
local libdir=$(get_libdir)
@@ -53,9 +58,7 @@ multilib_src_configure() {
# also separately bug #863917
filter-lto
- if use clang && ! tc-is-clang; then
- # Only do this conditionally to allow overriding with
- # e.g. CC=clang-13 in case of breakage
+ if use clang; then
local -x CC=${CHOST}-clang
local -x CXX=${CHOST}-clang++
strip-unsupported-flags
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-16.0.0.9999.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-16.0.0.9999.ebuild
index c682d12707f2..67d11a24dc77 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-16.0.0.9999.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-16.0.0.9999.ebuild
@@ -20,13 +20,13 @@ RESTRICT="!test? ( test )"
RDEPEND="
!sys-libs/libunwind
"
-# llvm-6 for new lit options
+LLVM_MAX_SLOT=${PV%%.*}
DEPEND="
- >=sys-devel/llvm-6
+ sys-devel/llvm:${LLVM_MAX_SLOT}
"
BDEPEND="
clang? (
- sys-devel/clang
+ sys-devel/clang:${LLVM_MAX_SLOT}
)
!test? (
${PYTHON_DEPS}
@@ -45,6 +45,11 @@ python_check_deps() {
python_has_version "dev-python/lit[${PYTHON_USEDEP}]"
}
+pkg_setup() {
+ llvm_pkg_setup
+ python-any-r1_pkg_setup
+}
+
multilib_src_configure() {
local use_compiler_rt=OFF
local libdir=$(get_libdir)
@@ -53,9 +58,7 @@ multilib_src_configure() {
# also separately bug #863917
filter-lto
- if use clang && ! tc-is-clang; then
- # Only do this conditionally to allow overriding with
- # e.g. CC=clang-13 in case of breakage
+ if use clang; then
local -x CC=${CHOST}-clang
local -x CXX=${CHOST}-clang++
strip-unsupported-flags
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-16.0.0_pre20220918.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-16.0.0_pre20220918.ebuild
index c682d12707f2..67d11a24dc77 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-16.0.0_pre20220918.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-16.0.0_pre20220918.ebuild
@@ -20,13 +20,13 @@ RESTRICT="!test? ( test )"
RDEPEND="
!sys-libs/libunwind
"
-# llvm-6 for new lit options
+LLVM_MAX_SLOT=${PV%%.*}
DEPEND="
- >=sys-devel/llvm-6
+ sys-devel/llvm:${LLVM_MAX_SLOT}
"
BDEPEND="
clang? (
- sys-devel/clang
+ sys-devel/clang:${LLVM_MAX_SLOT}
)
!test? (
${PYTHON_DEPS}
@@ -45,6 +45,11 @@ python_check_deps() {
python_has_version "dev-python/lit[${PYTHON_USEDEP}]"
}
+pkg_setup() {
+ llvm_pkg_setup
+ python-any-r1_pkg_setup
+}
+
multilib_src_configure() {
local use_compiler_rt=OFF
local libdir=$(get_libdir)
@@ -53,9 +58,7 @@ multilib_src_configure() {
# also separately bug #863917
filter-lto
- if use clang && ! tc-is-clang; then
- # Only do this conditionally to allow overriding with
- # e.g. CC=clang-13 in case of breakage
+ if use clang; then
local -x CC=${CHOST}-clang
local -x CXX=${CHOST}-clang++
strip-unsupported-flags