summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-04-26 12:14:48 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-04-26 12:32:55 +0200
commitfe1df4865ab6a3ab1433183afda0aee11cb68c88 (patch)
tree5438f1236c62f6feaaaee35c64817f5aa949db8e /sys-libs/snapd-glib
parentsys-apps/intune-portal: New package at 1.2402.12 (diff)
downloadgentoo-fe1df4865ab6a3ab1433183afda0aee11cb68c88.tar.gz
gentoo-fe1df4865ab6a3ab1433183afda0aee11cb68c88.tar.bz2
gentoo-fe1df4865ab6a3ab1433183afda0aee11cb68c88.zip
sys-libs/snapd-glib: add 1.65
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sys-libs/snapd-glib')
-rw-r--r--sys-libs/snapd-glib/Manifest1
-rw-r--r--sys-libs/snapd-glib/snapd-glib-1.65.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/sys-libs/snapd-glib/Manifest b/sys-libs/snapd-glib/Manifest
index 094164411d98..ef8ecea50050 100644
--- a/sys-libs/snapd-glib/Manifest
+++ b/sys-libs/snapd-glib/Manifest
@@ -1,2 +1,3 @@
DIST snapd-glib-1.63.tar.xz 187676 BLAKE2B a212f826ee35ef5458b716ce64d8f4b32474f991938bc314fcdb0feb5c803f93880a517fe5e1550bc82bc4992bee7467dc0d8cf5cb260712e83b8a1fe6b75743 SHA512 94a2f46e4e066270ea5492cb00fd44da247686a354cbe6766fe3e8974e6bb51f4cf1ca95027533417ec8c8117fc9d3866cb173a113b89d789b6ba518489a314f
DIST snapd-glib-1.64.tar.xz 195580 BLAKE2B 1c6e958033c2b98dd72b5bfb6f1a44739a79d5d9a289fded9756cf3031a1fe62cccbf3ba4ce4c4f34d3c7e48b945b481ff6c3ae245d205a49e37845dd3efbb27 SHA512 a3fa101bcc64b750c170ccd433dbbfaa306354dc6c66d5ab62911c866b7e65f6aefc7e9c82f84f5d16b8b96174edf4bef771a4839ef6e5acd15399a84b93aec4
+DIST snapd-glib-1.65.tar.xz 205948 BLAKE2B e5253cd6f8ac908236a89bf8fa3ec2252d2e4bb0875c6860b63808663d80d59d0a5397a5170ac959492e720e1c8fe77d9674a6469cc58556073cf93888da9a8b SHA512 6bae381c6b5a83312004026228ee76e7b8722a5a561c991ceda35aaf104eaf84451f5a7ba299cad6b1f82e3dbcb16cc4780ac393cadb2ca58478b59a809fc613
diff --git a/sys-libs/snapd-glib/snapd-glib-1.65.ebuild b/sys-libs/snapd-glib/snapd-glib-1.65.ebuild
new file mode 100644
index 000000000000..e8d848523dfa
--- /dev/null
+++ b/sys-libs/snapd-glib/snapd-glib-1.65.ebuild
@@ -0,0 +1,88 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson vala
+
+DESCRIPTION="glib library for communicating with snapd"
+HOMEPAGE="https://snapcraft.io/"
+SRC_URI="https://github.com/snapcore/snapd-glib/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="LGPL-3"
+SLOT="0/1"
+KEYWORDS="~amd64"
+
+IUSE="doc introspection qml qt5 qt6 vala"
+REQUIRED_USE="
+ qml? ( || ( qt5 qt6 ) )
+ vala? ( introspection )
+"
+
+BDEPEND="
+ virtual/pkgconfig
+ sys-devel/gettext
+ qt5? ( dev-qt/linguist-tools:5 )
+ qt6? ( dev-qt/qttools:6[linguist] )
+"
+
+DEPEND="
+ dev-libs/json-glib
+ dev-libs/glib:2
+ dev-util/glib-utils
+ net-libs/libsoup:3.0
+ doc? ( dev-util/gtk-doc )
+ introspection? ( dev-libs/gobject-introspection )
+ qml? (
+ qt5? ( dev-qt/qtdeclarative:5 )
+ qt6? ( dev-qt/qtdeclarative:6 )
+ )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ )
+ qt6? (
+ dev-qt/qtbase:6[network,widgets]
+ )
+ vala? ( $(vala_depend) )
+"
+
+RDEPEND="${DEPEND}
+ app-containers/snapd
+"
+
+pkg_setup() {
+ vala_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ "$(meson_use doc docs)"
+ "$(meson_use introspection)"
+ "$(meson_use qml qml-bindings)"
+ "$(meson_use qt5)"
+ "$(meson_use qt6)"
+ "$(meson_use vala vala-bindings)"
+ -Dsoup2=false
+ )
+
+ if use qt5; then
+ emesonargs+=(
+ -Dqt5=true
+ -Dqt6=false
+ )
+ elif use qt6; then
+ emesonargs+=(
+ -Dqt5=false
+ -Dqt6=true
+ )
+ else
+ emesonargs+=(
+ -Dqt5=false
+ -Dqt6=false
+ )
+ fi
+
+ meson_src_configure
+}