summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2018-01-26 14:33:17 -0500
committerAnthony G. Basile <blueness@gentoo.org>2018-01-26 14:33:35 -0500
commit09642f6cdb5b3e70896c6cb307d8d80d2adb07e7 (patch)
tree61f1a84e6dfd0ec868df34baa33d625c50fca466 /sys-libs/uclibc-ng/uclibc-ng-9999.ebuild
parentdev-php/PEAR-PEAR: add keywords ~s390 and ~sh (would otherwise be dropped). (diff)
downloadgentoo-09642f6cdb5b3e70896c6cb307d8d80d2adb07e7.tar.gz
gentoo-09642f6cdb5b3e70896c6cb307d8d80d2adb07e7.tar.bz2
gentoo-09642f6cdb5b3e70896c6cb307d8d80d2adb07e7.zip
sys-libs/uclibc-ng: version bump to 1.0.28
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'sys-libs/uclibc-ng/uclibc-ng-9999.ebuild')
-rw-r--r--sys-libs/uclibc-ng/uclibc-ng-9999.ebuild17
1 files changed, 4 insertions, 13 deletions
diff --git a/sys-libs/uclibc-ng/uclibc-ng-9999.ebuild b/sys-libs/uclibc-ng/uclibc-ng-9999.ebuild
index 9c2e972dc4c0..507f8c13ae96 100644
--- a/sys-libs/uclibc-ng/uclibc-ng-9999.ebuild
+++ b/sys-libs/uclibc-ng/uclibc-ng-9999.ebuild
@@ -14,7 +14,7 @@ else
fi
DESCRIPTION="C library for developing embedded Linux systems"
-HOMEPAGE="http://www.uclibc-ng.org/"
+HOMEPAGE="https://uclibc-ng.org/"
if [[ ${PV} != "9999" ]] ; then
PATCH_VER=""
SRC_URI="http://downloads.uclibc-ng.org/releases/${PV}/${MY_P}.tar.bz2"
@@ -23,7 +23,7 @@ fi
LICENSE="LGPL-2"
SLOT="0"
-IUSE="debug hardened iconv ipv6 rpc symlink-compat headers-only"
+IUSE="debug hardened iconv ipv6 symlink-compat headers-only"
RESTRICT="strip"
# 1) We can't upgrade from uclibc to uclibc-ng via a soft blocker since portage
@@ -121,21 +121,19 @@ make_config() {
SUPPORT_LD_DEBUG_EARLY
UCLIBC_HAS_CTYPE_UNSAFE
UCLIBC_HAS_LOCALE
- UCLIBC_HAS_SSP_COMPAT
+ LDSO_SAFE_RUNPATH
)
# These are forced on
defs_y=(
- COMPAT_ATEXIT
DO_C99_MATH
DO_XSI_MATH
FORCE_SHAREABLE_TEXT_SEGMENTS
LDSO_GNU_HASH_SUPPORT
- LDSO_PRELINK_SUPPORT
LDSO_PRELOAD_FILE_SUPPORT
+ LDSO_RUNPATH
LDSO_RUNPATH_OF_EXECUTABLE
LDSO_STANDALONE_SUPPORT
- MALLOC_GLIBC_COMPAT
PROPOLICE_BLOCK_SEGV
PTHREADS_DEBUG_SUPPORT
UCLIBC_HAS_ARC4RANDOM
@@ -155,12 +153,9 @@ make_config() {
UCLIBC_HAS_GLIBC_CUSTOM_STREAMS
UCLIBC_HAS_GNU_GLOB
UCLIBC_HAS_HEXADECIMAL_FLOATS
- UCLIBC_HAS_LIBNSL_STUB
- UCLIBC_HAS_LIBRESOLV_STUB
UCLIBC_HAS_LIBUTIL
UCLIBC_HAS_NFTW
UCLIBC_HAS_OBSOLETE_BSD_SIGNAL
- UCLIBC_HAS_OBSTACK
UCLIBC_HAS_PRINTF_M_SPEC
UCLIBC_HAS_PROGRAM_INVOCATION_NAME
UCLIBC_HAS_RESOLVER_SUPPORT
@@ -194,10 +189,6 @@ make_config() {
kconfig_q_opt ipv6 UCLIBC_HAS_IPV6
- kconfig_q_opt rpc UCLIBC_HAS_RPC
- kconfig_q_opt rpc UCLIBC_HAS_FULL_RPC
- kconfig_q_opt rpc UCLIBC_HAS_REENTRANT_RPC
-
kconfig_q_opt hardened UCLIBC_BUILD_NOEXECSTACK
kconfig_q_opt hardened UCLIBC_BUILD_NOW
kconfig_q_opt hardened UCLIBC_BUILD_PIE