summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-02-09 11:07:41 +0100
committerMichał Górny <mgorny@gentoo.org>2018-02-09 17:00:04 +0100
commit7c8d007596c7772209bdbc02b22a071b1c0faadd (patch)
tree2118df913701a039e9535e30fa55715f89164967 /sys-libs
parentsys-libs/compiler-rt-sanitizers: Bump to 6.0.0rc2 (diff)
downloadgentoo-7c8d007596c7772209bdbc02b22a071b1c0faadd.tar.gz
gentoo-7c8d007596c7772209bdbc02b22a071b1c0faadd.tar.bz2
gentoo-7c8d007596c7772209bdbc02b22a071b1c0faadd.zip
sys-libs/llvm-libunwind: libcxx is only needed for tests (*9999)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-6.0.9999.ebuild8
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild8
2 files changed, 10 insertions, 6 deletions
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-6.0.9999.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-6.0.9999.ebuild
index 0be3b4e8c29e..7523ff7bd6f6 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-6.0.9999.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-6.0.9999.ebuild
@@ -47,9 +47,11 @@ src_unpack() {
https://github.com/llvm-mirror/libcxx.git"
git-r3_fetch
- git-r3_checkout https://llvm.org/git/libcxx.git \
- "${WORKDIR}"/libcxx '' include utils/libcxx
- git-r3_checkout
+ if use test; then
+ git-r3_checkout https://llvm.org/git/libcxx.git \
+ "${WORKDIR}"/libcxx '' include utils/libcxx
+ git-r3_checkout
+ fi
}
multilib_src_configure() {
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild
index c10226761668..60a321c7d609 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild
@@ -46,9 +46,11 @@ src_unpack() {
https://github.com/llvm-mirror/libcxx.git"
git-r3_fetch
- git-r3_checkout https://llvm.org/git/libcxx.git \
- "${WORKDIR}"/libcxx '' include utils/libcxx
- git-r3_checkout
+ if use test; then
+ git-r3_checkout https://llvm.org/git/libcxx.git \
+ "${WORKDIR}"/libcxx '' include utils/libcxx
+ git-r3_checkout
+ fi
}
multilib_src_configure() {