summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-17 23:27:11 +0000
committerLars Wendler <polynomial-c@gentoo.org>2021-03-22 09:57:44 +0100
commitd3669bc09318c3108d9a5d4581ce84f0aa32bd2b (patch)
tree0870acbc69e504c9f339b2e9995098a09d71ce8a /sys-libs
parentprofiles/arch/sparc: mask sys-apps/grep[static] for now (diff)
downloadgentoo-d3669bc09318c3108d9a5d4581ce84f0aa32bd2b.tar.gz
gentoo-d3669bc09318c3108d9a5d4581ce84f0aa32bd2b.tar.bz2
gentoo-d3669bc09318c3108d9a5d4581ce84f0aa32bd2b.zip
sys-libs/zlib-ng: revbump for forthcoming changes, cosmetic bits
We're about to make several fixes including a blocker. Revbumping ensures that everybody has these fixes but also makes subsequent commits have easier-to-review diffs. Also: * Adjust ebuild layout * Update DESCRIPTION to indicate fork * Add bug reference to libdir workaround * Adjust metadata indentation Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/zlib-ng/metadata.xml20
-rw-r--r--sys-libs/zlib-ng/zlib-ng-2.0.1-r1.ebuild (renamed from sys-libs/zlib-ng/zlib-ng-2.0.1.ebuild)7
2 files changed, 14 insertions, 13 deletions
diff --git a/sys-libs/zlib-ng/metadata.xml b/sys-libs/zlib-ng/metadata.xml
index 44db40fcc5ea..af26df0fdf9f 100644
--- a/sys-libs/zlib-ng/metadata.xml
+++ b/sys-libs/zlib-ng/metadata.xml
@@ -1,14 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="project">
- <email>base-system@gentoo.org</email>
- <name>Gentoo Base System</name>
-</maintainer>
-<use>
- <flag name="compat">Enable compatibility to <pkg>sys-libs/zlib</pkg></flag>
-</use>
-<upstream>
- <remote-id type="github">zlib-ng/zlib-ng</remote-id>
-</upstream>
+ <maintainer type="project">
+ <email>base-system@gentoo.org</email>
+ <name>Gentoo Base System</name>
+ </maintainer>
+ <use>
+ <flag name="compat">Enable compatibility to <pkg>sys-libs/zlib</pkg></flag>
+ </use>
+ <upstream>
+ <remote-id type="github">zlib-ng/zlib-ng</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/sys-libs/zlib-ng/zlib-ng-2.0.1.ebuild b/sys-libs/zlib-ng/zlib-ng-2.0.1-r1.ebuild
index 6c9d4fdc34fb..bb16ca91c101 100644
--- a/sys-libs/zlib-ng/zlib-ng-2.0.1.ebuild
+++ b/sys-libs/zlib-ng/zlib-ng-2.0.1-r1.ebuild
@@ -1,17 +1,16 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# $Id: 688f948c5f3067e775bfab5057e8047f467a9ca9 $
EAPI=7
inherit cmake
-DESCRIPTION="zlib data compression library"
+DESCRIPTION="Fork of the zlib data compression library"
HOMEPAGE="https://github.com/zlib-ng/zlib-ng"
SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
LICENSE="ZLIB"
SLOT="0"
-
#KEYWORDS="~amd64 ~x86"
IUSE="compat test"
@@ -19,6 +18,8 @@ RESTRICT="!test? ( test )"
src_prepare() {
cmake_src_prepare
+
+ # https://github.com/zlib-ng/zlib-ng/issues/881
sed "/LIB_INSTALL_DIR/s@/lib\"@/$(get_libdir)\"@" \
-i CMakeLists.txt || die
}