summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2023-03-31 12:05:12 -0700
committerPatrick McLean <chutzpah@gentoo.org>2023-03-31 12:13:04 -0700
commiteadfa6b70221cce5fc2ce3cc5d250d3b0f52b9e4 (patch)
tree508866ed6cb96d145072e5f679ca637ab830caef /sys-libs
parentapp-office/calligra: Drop unused dev-qt/qtscript dependency (diff)
downloadgentoo-eadfa6b70221cce5fc2ce3cc5d250d3b0f52b9e4.tar.gz
gentoo-eadfa6b70221cce5fc2ce3cc5d250d3b0f52b9e4.tar.bz2
gentoo-eadfa6b70221cce5fc2ce3cc5d250d3b0f52b9e4.zip
sys-libs/libnvme: add 1.4
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libnvme/Manifest1
-rw-r--r--sys-libs/libnvme/libnvme-1.4.ebuild73
-rw-r--r--sys-libs/libnvme/metadata.xml1
3 files changed, 75 insertions, 0 deletions
diff --git a/sys-libs/libnvme/Manifest b/sys-libs/libnvme/Manifest
index accefee6a64f..1a31f5c798ea 100644
--- a/sys-libs/libnvme/Manifest
+++ b/sys-libs/libnvme/Manifest
@@ -1,2 +1,3 @@
DIST libnvme-1.2.tar.gz 484397 BLAKE2B ae6b1c3aa8f45594219470059cfc8982674433772f89faab1659811d860036f8af89bbcb383db37e96b763188935d2c1ecaa5176b8140bba50f8ea226e989a06 SHA512 f50517838cd1df3cdd123afdb67870633e9e484bf84dba70b784d7e86ecb355b96ba9d6a1cffb96b35444da7870dfe21c54b69701b5fe5b515319280db4a84e4
DIST libnvme-1.3.tar.gz 499870 BLAKE2B 5a019c12829890a0fe0b5e6aec5fbd009fc3bd6dfe7e81f61731292f4ea8b03044e7625491479350c399cc8cd5bc023e02cc9e93f1eba38f4c747667e84cfb24 SHA512 c874b29b73e55be842f71e74a226a76fcd50dfa72e2be100f0437bc83e740cd146b6d2f2cdaa940c11c3d8c48ff2c065ac0e8a83d4d0dde743edf4179f328670
+DIST libnvme-1.4.tar.gz 506101 BLAKE2B c1496c6258bf20ed4109710b06671fa7f0e27c7649520ad8ccf4021df00fffc45f80fea248d62d2b85eecc8b15b6afaf4a113d96d6737ae6772346c9d0bc1002 SHA512 cc4a0a78083471e912736d76e4faaa5c285e1149029560f212ff06254863e8f21b48fcb1638599bd68efcf888312a248fb748d23776af03574b39fbd9b2a418d
diff --git a/sys-libs/libnvme/libnvme-1.4.ebuild b/sys-libs/libnvme/libnvme-1.4.ebuild
new file mode 100644
index 000000000000..eebf0dc02112
--- /dev/null
+++ b/sys-libs/libnvme/libnvme-1.4.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+inherit python-r1 meson
+
+DESCRIPTION="C Library for NVM Express on Linux"
+HOMEPAGE="https://github.com/linux-nvme/libnvme"
+LICENSE="LGPL-2.1+"
+SLOT="0/1"
+IUSE="dbus +json keyutils python ssl +uuid"
+
+SRC_URI="https://github.com/linux-nvme/libnvme/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ json? ( dev-libs/json-c:= )
+ keyutils? ( sys-apps/keyutils:= )
+ dbus? ( sys-apps/dbus:= )
+ python? ( ${PYTHON_DEPS} )
+ ssl? ( >=dev-libs/openssl-1.1:= )
+ uuid? ( sys-apps/util-linux:= )
+"
+RDEPEND="${DEPEND}"
+
+BDEPEND="
+ dev-lang/swig
+"
+
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dpython=false
+ $(meson_feature json json-c)
+ $(meson_feature dbus libdbus)
+ $(meson_feature ssl openssl)
+ $(meson_feature python)
+ )
+ meson_src_configure
+}
+
+python_compile() {
+ local emesonargs=(
+ -Dpython=enabled
+ )
+ meson_src_configure --reconfigure
+ meson_src_compile
+}
+
+src_compile() {
+ meson_src_compile
+
+ if use python; then
+ python_copy_sources
+ python_foreach_impl python_compile
+ fi
+}
+
+python_install() {
+ meson_src_install
+ use python && python_optimize
+}
+
+src_install() {
+ use python && python_foreach_impl python_install
+
+ meson_src_install
+}
diff --git a/sys-libs/libnvme/metadata.xml b/sys-libs/libnvme/metadata.xml
index 929132b037bd..b8882391c6fc 100644
--- a/sys-libs/libnvme/metadata.xml
+++ b/sys-libs/libnvme/metadata.xml
@@ -7,6 +7,7 @@
</maintainer>
<use>
<flag name="json">Support JSON output via <pkg>dev-libs/json-c</pkg></flag>
+ <flag name="keyutils">Add support for <pkg>sys-apps/keyutils</pkg></flag>
<flag name="uuid">UUID support via <pkg>sys-apps/util-linux</pkg></flag>
</use>
<upstream>