summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-28 14:02:33 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-28 14:57:09 +0200
commitfbefb0fc3ed52f8c8cc626b087098a45e6148d7e (patch)
tree464bd6f68567f062e9046c10b3bcfed90348bef2 /sys-libs
parentsys-libs/compiler-rt-sanitizers: Check llvm/cmake out for 15.x (diff)
downloadgentoo-fbefb0fc3ed52f8c8cc626b087098a45e6148d7e.tar.gz
gentoo-fbefb0fc3ed52f8c8cc626b087098a45e6148d7e.tar.bz2
gentoo-fbefb0fc3ed52f8c8cc626b087098a45e6148d7e.zip
sys-libs/libcxxabi: Fix 15.x with USE=-libunwind
Still need to figure out USE=libunwind and tests. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libcxxabi/libcxxabi-15.0.0.9999.ebuild12
1 files changed, 4 insertions, 8 deletions
diff --git a/sys-libs/libcxxabi/libcxxabi-15.0.0.9999.ebuild b/sys-libs/libcxxabi/libcxxabi-15.0.0.9999.ebuild
index 15858fc7fc75..6655441055a6 100644
--- a/sys-libs/libcxxabi/libcxxabi-15.0.0.9999.ebuild
+++ b/sys-libs/libcxxabi/libcxxabi-15.0.0.9999.ebuild
@@ -24,6 +24,10 @@ RDEPEND="
)
)
"
+# in 15.x, cxxabi.h is moving from libcxx to libcxxabi
+RDEPEND+="
+ !<sys-libs/libcxx-15
+"
# llvm-6 for new lit options
DEPEND="
${RDEPEND}
@@ -83,14 +87,11 @@ multilib_src_configure() {
# upstream is omitting standard search path for this
# probably because gcc & clang are bundling their own unwind.h
-DLIBCXXABI_LIBUNWIND_INCLUDES="${EPREFIX}"/usr/include
- -DLIBCXXABI_TARGET_TRIPLE="${CHOST}"
-DLIBCXX_LIBDIR_SUFFIX=
-DLIBCXX_ENABLE_SHARED=ON
-DLIBCXX_ENABLE_STATIC=OFF
- -DLIBCXX_ENABLE_EXPERIMENTAL_LIBRARY=OFF
-DLIBCXX_CXX_ABI=libcxxabi
- -DLIBCXX_CXX_ABI_INCLUDE_PATHS="${WORKDIR}"/libcxxabi/include
-DLIBCXX_ENABLE_ABI_LINKER_SCRIPT=OFF
-DLIBCXX_HAS_MUSL_LIBC=$(usex elibc_musl)
-DLIBCXX_HAS_GCC_S_LIB=OFF
@@ -123,8 +124,3 @@ multilib_src_test() {
multilib_src_install() {
DESTDIR="${D}" cmake_build install-cxxabi
}
-
-multilib_src_install_all() {
- insinto /usr/include/libcxxabi
- doins -r "${WORKDIR}"/libcxxabi/include/.
-}