summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-power/phc-k8/phc-k8-0.4.3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-power/phc-k8/phc-k8-0.4.3.ebuild')
-rw-r--r--sys-power/phc-k8/phc-k8-0.4.3.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sys-power/phc-k8/phc-k8-0.4.3.ebuild b/sys-power/phc-k8/phc-k8-0.4.3.ebuild
new file mode 100644
index 000000000000..1b3d9f2b75ed
--- /dev/null
+++ b/sys-power/phc-k8/phc-k8-0.4.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit linux-info linux-mod
+
+DESCRIPTION="Processor Hardware Control for AMD K8 CPUs"
+HOMEPAGE="http://www.linux-phc.org/"
+SRC_URI="http://www.linux-phc.org/forum/download/file.php?id=107 -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S=${WORKDIR}/${PN}_v${PV}
+
+pkg_pretend() {
+ if kernel_is gt 3 0 0 ; then
+ eerror "This version is not compartible with linux 3.x (bug 376441)"
+ eerror "Please use >=sys-power/phc-k8-0.4.4 !"
+ einfo ; einfo ; einfo
+ die "wrong kernel version"
+ fi
+}
+
+pkg_setup() {
+ CONFIG_CHECK="~!X86_POWERNOW_K8"
+ ERROR_X86_POWERNOW_K8="CONFIG_X86_POWERNOW_K8 should be configured to Module, to
+a) include needed symbol cpufreq_get_measured_perf and
+b) enable the replacemant of powernow-k8 with phc-k8."
+
+ MODULE_NAMES="phc-k8(misc:)"
+ BUILD_PARAMS="KERNELSRC=\"${KERNEL_DIR}\" -j1"
+ BUILD_TARGETS="all"
+}
+
+src_install() {
+ linux-mod_src_install
+ dodoc Changelog README || die
+}