summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-process/anacron
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-process/anacron')
-rw-r--r--sys-process/anacron/Manifest1
-rw-r--r--sys-process/anacron/anacron-2.3-r2.ebuild62
-rw-r--r--sys-process/anacron/files/anacron-2.3-compile-fix-from-debian.patch11
-rwxr-xr-xsys-process/anacron/files/anacron.rc615
-rw-r--r--sys-process/anacron/files/anacrontab11
-rw-r--r--sys-process/anacron/metadata.xml8
6 files changed, 108 insertions, 0 deletions
diff --git a/sys-process/anacron/Manifest b/sys-process/anacron/Manifest
new file mode 100644
index 000000000000..b5eb761d83de
--- /dev/null
+++ b/sys-process/anacron/Manifest
@@ -0,0 +1 @@
+DIST anacron-2.3.tar.gz 24140 SHA256 5ceee6f22cd089bdaf1c0841200dbe5726babaf9e2c432bb17c1fc95da5ca99f SHA512 27bbbfad5bc35ddc68e4345c3a3acefd0a6f794aaba890f7c75ec42b2e4c4200fbb1667e75b2e344afb7722bdc9ba3dc5a7db66d3369808bc9f483ea3509849c WHIRLPOOL 119193e7a44855ab3844755ac0d912bc14d6ee55638a2979d7a107f99062c5f0f2bd27f45a429dcf0b8bfc3187c33b10374a0f6a83303a9539dd1eae95fd3d00
diff --git a/sys-process/anacron/anacron-2.3-r2.ebuild b/sys-process/anacron/anacron-2.3-r2.ebuild
new file mode 100644
index 000000000000..73102c1c6a3f
--- /dev/null
+++ b/sys-process/anacron/anacron-2.3-r2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="a periodic command scheduler"
+HOMEPAGE="http://anacron.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc x86"
+IUSE=""
+
+DEPEND=">=sys-apps/sed-4
+ sys-process/cronbase"
+RDEPEND="virtual/mta
+ virtual/cron"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-compile-fix-from-debian.patch
+ sed -i "s:^CFLAGS =:CFLAGS = $CFLAGS:" Makefile
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ #this does not work if the directory exists already
+ diropts -m0750 -o root -g cron
+ keepdir /var/spool/anacron
+
+ doman anacrontab.5 anacron.8
+
+ newinitd "${FILESDIR}"/anacron.rc6 anacron
+
+ dodoc ChangeLog README TODO
+
+ insinto /usr/sbin
+ insopts -o root -g root -m 0750 ; doins anacron
+
+ insinto /etc
+ doins "${FILESDIR}"/anacrontab
+}
+
+pkg_postinst() {
+ einfo "Schedule the command \"anacron -s\" as a daily cron-job (preferably"
+ einfo "at some early morning hour). This will make sure that jobs are run"
+ einfo "when the systems is left running for a night."
+ einfo ""
+ einfo "Update /etc/anacrontab to include what you want anacron to run."
+
+ echo
+ einfo "You may wish to read the Gentoo Linux Cron Guide, which can be"
+ einfo "found online at:"
+ einfo " http://www.gentoo.org/doc/en/cron-guide.xml"
+ echo
+}
diff --git a/sys-process/anacron/files/anacron-2.3-compile-fix-from-debian.patch b/sys-process/anacron/files/anacron-2.3-compile-fix-from-debian.patch
new file mode 100644
index 000000000000..174a975f0ca3
--- /dev/null
+++ b/sys-process/anacron/files/anacron-2.3-compile-fix-from-debian.patch
@@ -0,0 +1,11 @@
+--- anacron-2.3/gregor.c 2000-06-23 02:00:14.000000000 +0200
++++ anacron-2.3-maks/gregor.c 2004-03-26 20:45:13.000000000 +0100
+@@ -65,7 +65,7 @@
+ {
+ int dn;
+ int i;
+- const int isleap; /* save three calls to leap() */
++ int isleap; /* save three calls to leap() */
+
+ /* Some validity checks */
+
diff --git a/sys-process/anacron/files/anacron.rc6 b/sys-process/anacron/files/anacron.rc6
new file mode 100755
index 000000000000..4e4a0a78e903
--- /dev/null
+++ b/sys-process/anacron/files/anacron.rc6
@@ -0,0 +1,15 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ use logger
+ need clock hostname
+}
+
+start() {
+ ebegin "Running anacron"
+ /usr/sbin/anacron -s >>/var/log/cron.log 2>&1
+ eend $?
+}
diff --git a/sys-process/anacron/files/anacrontab b/sys-process/anacron/files/anacrontab
new file mode 100644
index 000000000000..c279929fcb65
--- /dev/null
+++ b/sys-process/anacron/files/anacrontab
@@ -0,0 +1,11 @@
+SHELL=/bin/sh
+PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
+# format: period delay job-identifier command
+##
+## If you turn any of the following on, make sure that the
+## regular cron daemon does not run them also. This could
+## lead to double execution of the jobs.
+#1 5 cron.daily run-parts /etc/cron.daily
+#7 10 cron.weekly run-parts /etc/cron.weekly
+#30 15 cron.monthly run-parts /etc/cron.monthly
+
diff --git a/sys-process/anacron/metadata.xml b/sys-process/anacron/metadata.xml
new file mode 100644
index 000000000000..9ac2d4e1c668
--- /dev/null
+++ b/sys-process/anacron/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cron</herd>
+ <upstream>
+ <remote-id type="sourceforge">anacron</remote-id>
+ </upstream>
+</pkgmetadata>