summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-06-11 22:06:07 +0200
committerPacho Ramos <pacho@gentoo.org>2016-06-11 22:06:07 +0200
commit0e09450502ff1e00e391e77b5e559ab17b1589aa (patch)
tree39b7eb982539a5aae184f269fca93537a2e68a66 /sys-process/bcron
parentmail-mta/mini-qmail: Workaround parallel build failure (#398135) (diff)
downloadgentoo-0e09450502ff1e00e391e77b5e559ab17b1589aa.tar.gz
gentoo-0e09450502ff1e00e391e77b5e559ab17b1589aa.tar.bz2
gentoo-0e09450502ff1e00e391e77b5e559ab17b1589aa.zip
sys-process/bcron: Needs python2 for building (#569020)
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'sys-process/bcron')
-rw-r--r--sys-process/bcron/bcron-0.10.ebuild16
1 files changed, 11 insertions, 5 deletions
diff --git a/sys-process/bcron/bcron-0.10.ebuild b/sys-process/bcron/bcron-0.10.ebuild
index f9eaa6c9afe8..68c21fd94d2b 100644
--- a/sys-process/bcron/bcron-0.10.ebuild
+++ b/sys-process/bcron/bcron-0.10.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
+PYTHON_COMPAT=( python2_7 )
-inherit cron eutils multilib toolchain-funcs
+inherit cron eutils multilib python-any-r1 toolchain-funcs
DESCRIPTION="A new cron system designed with secure operations in mind by Bruce Guenter"
HOMEPAGE="http://untroubled.org/bcron/"
@@ -14,12 +15,17 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-DEPEND=">=dev-libs/bglibs-1.106"
-RDEPEND="${DEPEND}
+RDEPEND="
>=sys-process/cronbase-0.3.2
virtual/mta
sys-apps/ucspi-unix
- virtual/daemontools"
+ virtual/daemontools
+"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ >=dev-libs/bglibs-1.106
+"
+
CRON_SYSTEM_CRONTAB="yes"