summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-15 16:12:42 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-15 16:12:55 +0100
commit5d4129aba42824c0587957c470959ec9bda1866e (patch)
tree0d2803952bc1974d0f264446e372003c2f01083b /sys-process/criu
parentsys-process/criu: add missing dep on libnl:3 (diff)
downloadgentoo-5d4129aba42824c0587957c470959ec9bda1866e.tar.gz
gentoo-5d4129aba42824c0587957c470959ec9bda1866e.tar.bz2
gentoo-5d4129aba42824c0587957c470959ec9bda1866e.zip
sys-process/criu: inject SYSROOT into the makefiles for libnl3 cflags so that target include dir is used instead of host.
Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'sys-process/criu')
-rw-r--r--sys-process/criu/criu-2.0.ebuild1
-rw-r--r--sys-process/criu/files/2.0/criu-2.0-sysroot.patch15
2 files changed, 16 insertions, 0 deletions
diff --git a/sys-process/criu/criu-2.0.ebuild b/sys-process/criu/criu-2.0.ebuild
index c1c17f8b4b55..b8c219841a70 100644
--- a/sys-process/criu/criu-2.0.ebuild
+++ b/sys-process/criu/criu-2.0.ebuild
@@ -39,6 +39,7 @@ src_prepare() {
epatch "${FILESDIR}"/${PV}/${P}-flags.patch
epatch "${FILESDIR}"/${PV}/${P}-makefile.patch
epatch "${FILESDIR}"/${PV}/${P}-automagic-libbsd.patch
+ epatch "${FILESDIR}"/${PV}/${P}-sysroot.patch
}
criu_arch() {
diff --git a/sys-process/criu/files/2.0/criu-2.0-sysroot.patch b/sys-process/criu/files/2.0/criu-2.0-sysroot.patch
new file mode 100644
index 000000000000..333c564c19ed
--- /dev/null
+++ b/sys-process/criu/files/2.0/criu-2.0-sysroot.patch
@@ -0,0 +1,15 @@
+Using host headers when cross compiling is not a great idea.
+
+Index: criu-2.0/criu/Makefile
+===================================================================
+--- criu-2.0.orig/criu/Makefile
++++ criu-2.0/criu/Makefile
+@@ -51,7 +51,7 @@ ccflags-y += -iquote $(SRC_DIR)/criu/pi
+ ccflags-y += -iquote $(SRC_DIR)/criu/$(ARCH_DIR)
+ ccflags-y += -iquote $(SRC_DIR)/criu/$(ARCH_DIR)/include
+ ccflags-y += -iquote $(SRC_DIR)/
+-ccflags-y += -I/usr/include/libnl3
++ccflags-y += -I${SYSROOT}/usr/include/libnl3
+
+ export ccflags-y
+