summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-04-20 21:38:38 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-04-20 21:38:38 +0300
commit4584214a24ecca2e210cbd8eb5565f358bb01e0c (patch)
tree4da3f248aa7ceebb19756fb69c975011c8b7786c /sys-process
parentsys-process/minit: scrub-patch (diff)
downloadgentoo-4584214a24ecca2e210cbd8eb5565f358bb01e0c.tar.gz
gentoo-4584214a24ecca2e210cbd8eb5565f358bb01e0c.tar.bz2
gentoo-4584214a24ecca2e210cbd8eb5565f358bb01e0c.zip
sys-process/minit: EAPI=8
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/minit/minit-0.10-r2.ebuild (renamed from sys-process/minit/minit-0.10-r1.ebuild)17
1 files changed, 10 insertions, 7 deletions
diff --git a/sys-process/minit/minit-0.10-r1.ebuild b/sys-process/minit/minit-0.10-r2.ebuild
index 38f8edebd305..06ea79028377 100644
--- a/sys-process/minit/minit-0.10-r1.ebuild
+++ b/sys-process/minit/minit-0.10-r2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit toolchain-funcs
@@ -15,8 +15,8 @@ KEYWORDS="amd64 x86"
DEPEND="
dev-libs/libowfat
- dev-libs/dietlibc"
-
+ dev-libs/dietlibc
+"
RDEPEND="${DEPEND}"
PATCHES=(
@@ -26,10 +26,13 @@ PATCHES=(
DOCS=( CHANGES README TODO )
src_compile() {
- emake CFLAGS="${CFLAGS} -I/usr/include/libowfat" \
- LDFLAGS="${LDFLAGS}" \
- DIET="diet"\
+ local mymakeflags=(
+ CFLAGS="${CFLAGS} -I/usr/include/libowfat"
+ LDFLAGS="${LDFLAGS}"
+ DIET="diet"
CC="$(tc-getCC)"
+ )
+ emake "${mymakeflags[@]}"
}
src_install() {