summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-01-24 20:25:31 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-01-24 20:26:06 +0200
commit83f2963bccbe77f4b7f5ab1c22d276ec31eda15e (patch)
treeb9deb3b8953cfacd6c18359b7937cc636b512990 /sys-process
parentdev-ml/lwt_log: bump to 1.1.2 (diff)
downloadgentoo-83f2963bccbe77f4b7f5ab1c22d276ec31eda15e.tar.gz
gentoo-83f2963bccbe77f4b7f5ab1c22d276ec31eda15e.tar.bz2
gentoo-83f2963bccbe77f4b7f5ab1c22d276ec31eda15e.zip
sys-process/iotop-c: add 1.23
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/iotop-c/Manifest1
-rw-r--r--sys-process/iotop-c/iotop-c-1.23.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/sys-process/iotop-c/Manifest b/sys-process/iotop-c/Manifest
index faf114d25606..2ef5cdf878a6 100644
--- a/sys-process/iotop-c/Manifest
+++ b/sys-process/iotop-c/Manifest
@@ -1 +1,2 @@
DIST iotop-c-1.22.tar.gz 135078 BLAKE2B 90a441402b19ab5af9d5155f5d335e992e8acd702cbc2ebfb4b99dbc0be672fe07d462aab2c00a14702f584c0762b3b0ae4336022007bc956309ab781cbd2aa8 SHA512 863f4e602e13c91302ef3e2de7bf917418cb389a427fd0a6579c31a991d628112d0b479a2287944c4b3f3b5c4b13815ec57d30687fc48de7b782586e56ee62d8
+DIST iotop-c-1.23.tar.gz 138772 BLAKE2B 123995c5af48f2d257a4c4b2f342c3cb656d91105e13200baac63c3bd5bdd68a09cf4991363db4d49b211f0ad75285b3f34e66951aa80b2df55f6728c54629dc SHA512 afdc59373e96f23efaf93a661ca31d101732b36e61631844864692599b0e5a1d2355fdda0ec994a8e9ed03bc7f6a37c4dd16336fb750084294d58bfcfc6e7f17
diff --git a/sys-process/iotop-c/iotop-c-1.23.ebuild b/sys-process/iotop-c/iotop-c-1.23.ebuild
new file mode 100644
index 000000000000..cdcb518ceb8f
--- /dev/null
+++ b/sys-process/iotop-c/iotop-c-1.23.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit fcaps linux-info toolchain-funcs
+
+DESCRIPTION="top utility for IO (C port)"
+HOMEPAGE="https://github.com/Tomas-M/iotop"
+SRC_URI="https://github.com/Tomas-M/iotop/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/iotop-${PV}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~x86"
+
+RDEPEND="sys-libs/ncurses:=
+ !sys-process/iotop"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+CONFIG_CHECK="~TASK_IO_ACCOUNTING ~TASK_DELAY_ACCT ~TASKSTATS ~VM_EVENT_COUNTERS"
+
+FILECAPS=(
+ cap_net_admin=eip usr/bin/iotop
+)
+
+src_compile() {
+ emake V=1 CC="$(tc-getCC)" PKG_CONFIG="$(tc-getPKG_CONFIG)" NO_FLTO=1
+}
+
+src_install() {
+ dobin iotop
+ dodoc README.md
+ doman iotop.8
+}