summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (navi) Figueiredo Gomes <navi@vlhl.dev>2024-05-17 03:21:38 +0200
committerSam James <sam@gentoo.org>2024-05-31 22:03:05 +0100
commit7d2266c767b01d9f89c0a7574306b8a888053f8a (patch)
tree2f18e13c459a6bfaf0a457d7e3286984d6ed25aa /virtual
parentsys-devel/rust-std: add 1.78.0 (diff)
downloadgentoo-7d2266c767b01d9f89c0a7574306b8a888053f8a.tar.gz
gentoo-7d2266c767b01d9f89c0a7574306b8a888053f8a.tar.bz2
gentoo-7d2266c767b01d9f89c0a7574306b8a888053f8a.zip
virtual/rust: add 1.78.0
Signed-off-by: Anna (navi) Figueiredo Gomes <navi@vlhl.dev> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'virtual')
-rw-r--r--virtual/rust/rust-1.78.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/virtual/rust/rust-1.78.0.ebuild b/virtual/rust/rust-1.78.0.ebuild
new file mode 100644
index 000000000000..89d91522025f
--- /dev/null
+++ b/virtual/rust/rust-1.78.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for Rust language compiler"
+
+LICENSE=""
+
+# adjust when rust upstream bumps internal llvm
+# we do not allow multiple llvm versions in dev-lang/rust for
+# neither system nor bundled, so we just hardcode it here.
+SLOT="0/llvm-18"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="rustfmt profiler"
+
+BDEPEND=""
+RDEPEND="|| (
+ ~dev-lang/rust-bin-${PV}[profiler?,rustfmt?,${MULTILIB_USEDEP}]
+ ~dev-lang/rust-${PV}[profiler?,rustfmt?,${MULTILIB_USEDEP}]
+)"