summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-06-01 15:49:57 -0400
committerMike Frysinger <vapier@gentoo.org>2016-06-01 16:26:08 -0400
commit468a4b50c52428ed43b2a595901339bff5c10dd6 (patch)
tree67f874b093147cf1bb38a6165da21f57507ee039 /www-apache/mod_h2/mod_h2-1.4.7.ebuild
parentwww-client/chromium: dev channel bump (52.0.2743.10) (diff)
downloadgentoo-468a4b50c52428ed43b2a595901339bff5c10dd6.tar.gz
gentoo-468a4b50c52428ed43b2a595901339bff5c10dd6.tar.bz2
gentoo-468a4b50c52428ed43b2a595901339bff5c10dd6.zip
www-apache/mod_h2: update to newer pre-releases
These are meant to be used in conjunction with newer apache releases so fixes to just the mod_http2 module can be tested.
Diffstat (limited to 'www-apache/mod_h2/mod_h2-1.4.7.ebuild')
-rw-r--r--www-apache/mod_h2/mod_h2-1.4.7.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/www-apache/mod_h2/mod_h2-1.4.7.ebuild b/www-apache/mod_h2/mod_h2-1.4.7.ebuild
new file mode 100644
index 000000000000..48f0e8ef3707
--- /dev/null
+++ b/www-apache/mod_h2/mod_h2-1.4.7.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit apache-module
+
+MY_P="${PN/h2/http2}-${PV}"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/icing/mod_h2.git"
+ inherit git-2
+else
+ SRC_URI="https://github.com/icing/mod_h2/releases/download/v${PV}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="HTTP/2 module for Apache"
+HOMEPAGE="https://github.com/icing/mod_h2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="ssl"
+
+RDEPEND=">=net-libs/nghttp2-1.0
+ >=www-servers/apache-2.4.20[-apache2_modules_http2,ssl?]"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+need_apache2_4
+
+src_configure() {
+ econf \
+ --docdir='$(datarootdir)'/doc/${PF} \
+ --disable-werror
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ default
+
+ APACHE2_MOD_DEFINE="HTTP2"
+ insinto "${APACHE_MODULES_CONFDIR}"
+ newins "${FILESDIR}/mod_http2.conf" "41_mod_http2.conf"
+}