summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThamognya Kodi <contact@thamognya.com>2022-05-27 05:29:20 +0700
committerJoonas Niilola <juippis@gentoo.org>2022-06-12 09:56:10 +0300
commit212806d5a45335d19b495d3a74e04b5d6326d805 (patch)
treefe1277251d067b4210fded49402d5af3cdd0ca6c /www-apps/gitea
parentdev-vcs/git-lfs: Bump to 3.2.0 (diff)
downloadgentoo-212806d5a45335d19b495d3a74e04b5d6326d805.tar.gz
gentoo-212806d5a45335d19b495d3a74e04b5d6326d805.tar.bz2
gentoo-212806d5a45335d19b495d3a74e04b5d6326d805.zip
www-apps/gitea: Bump to 1.16.8
Signed-off-by: Thamognya Kodi <contact@thamognya.com> Closes: https://github.com/gentoo/gentoo/pull/25654 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'www-apps/gitea')
-rw-r--r--www-apps/gitea/Manifest1
-rw-r--r--www-apps/gitea/gitea-1.16.8.ebuild125
-rw-r--r--www-apps/gitea/metadata.xml21
3 files changed, 140 insertions, 7 deletions
diff --git a/www-apps/gitea/Manifest b/www-apps/gitea/Manifest
index f6aed33a2f19..1313daf5d6d6 100644
--- a/www-apps/gitea/Manifest
+++ b/www-apps/gitea/Manifest
@@ -1 +1,2 @@
DIST gitea-1.16.7.tar.gz 53657579 BLAKE2B ae9d67fa633bcc5156036f033a4ed084b5b6ac0d71ec6a1ec0d0c88848233f3f0f0c22ca1c33289dc0e9950a8b299e26a88417e03643972f6721f94097b37d85 SHA512 7a31330e46078e215eecfbb2ec28373be1a176790720afbcf9674f3530d66f300d8ef9e47b9b9124cda9ce585d26d40c975e4897e5a3477dcec28b6f2b16735c
+DIST gitea-1.16.8.tar.gz 53659731 BLAKE2B ee35388d9fc5ba202d9b013e36b12771e55bc3d26256ec11ab1f1441b1db62e5b4e9972970b3f926d714edc40ac3b2e5daae47a16e2d76e4e49a1c367490cb02 SHA512 f502a07c886cc2f15615693a90eda128478d0de833cbe18993ed1f5a1a81f45591b2c00791f8024eda97d948991838b2dc95fab189695179631df47e4d587419
diff --git a/www-apps/gitea/gitea-1.16.8.ebuild b/www-apps/gitea/gitea-1.16.8.ebuild
new file mode 100644
index 000000000000..c4fad5faa314
--- /dev/null
+++ b/www-apps/gitea/gitea-1.16.8.ebuild
@@ -0,0 +1,125 @@
+# Copyright 2016-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit fcaps go-module tmpfiles systemd flag-o-matic
+
+DESCRIPTION="A painless self-hosted Git service"
+HOMEPAGE="https://gitea.io https://github.com/go-gitea/gitea"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/go-gitea/gitea.git"
+else
+ SRC_URI="https://github.com/go-gitea/gitea/releases/download/v${PV}/gitea-src-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64"
+fi
+
+S="${WORKDIR}"
+
+LICENSE="Apache-2.0 BSD BSD-2 ISC MIT MPL-2.0"
+SLOT="0"
+IUSE="+acct pam sqlite pie"
+
+DEPEND="
+ acct? (
+ acct-group/git
+ acct-user/git[gitea] )
+ pam? ( sys-libs/pam )"
+RDEPEND="${DEPEND}
+ dev-vcs/git"
+
+DOCS=(
+ custom/conf/app.example.ini CONTRIBUTING.md README.md
+)
+FILECAPS=(
+ -m 711 cap_net_bind_service+ep usr/bin/gitea
+)
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+
+ local sedcmds=(
+ -e "s#^ROOT =#ROOT = ${EPREFIX}/var/lib/gitea/gitea-repositories#"
+ -e "s#^ROOT_PATH =#ROOT_PATH = ${EPREFIX}/var/log/gitea#"
+ -e "s#^APP_DATA_PATH = data#APP_DATA_PATH = ${EPREFIX}/var/lib/gitea/data#"
+ -e "s#^HTTP_ADDR = 0.0.0.0#HTTP_ADDR = 127.0.0.1#"
+ -e "s#^MODE = console#MODE = file#"
+ -e "s#^LEVEL = Trace#LEVEL = Info#"
+ -e "s#^LOG_SQL = true#LOG_SQL = false#"
+ -e "s#^DISABLE_ROUTER_LOG = false#DISABLE_ROUTER_LOG = true#"
+ )
+
+ sed -i "${sedcmds[@]}" custom/conf/app.example.ini || die
+ if use sqlite ; then
+ sed -i -e "s#^DB_TYPE = .*#DB_TYPE = sqlite3#" custom/conf/app.example.ini || die
+ fi
+}
+
+src_configure() {
+ # bug 832756 - PIE build issues
+ filter-flags -fPIE
+ filter-ldflags -fPIE -pie
+}
+
+src_compile() {
+ local gitea_tags=(
+ bindata
+ $(usev pam)
+ $(usex sqlite 'sqlite sqlite_unlock_notify' '')
+ )
+ local gitea_settings=(
+ "-X code.gitea.io/gitea/modules/setting.CustomConf=${EPREFIX}/etc/gitea/app.ini"
+ "-X code.gitea.io/gitea/modules/setting.CustomPath=${EPREFIX}/var/lib/gitea/custom"
+ "-X code.gitea.io/gitea/modules/setting.AppWorkPath=${EPREFIX}/var/lib/gitea"
+ )
+ local makeenv=(
+ DRONE_TAG="${PV}"
+ LDFLAGS="-extldflags \"${LDFLAGS}\" ${gitea_settings[*]}"
+ TAGS="${gitea_tags[*]}"
+ )
+
+ GOFLAGS=""
+ if use pie ; then
+ GOFLAGS+="-buildmode=pie"
+ fi
+
+ env "${makeenv[@]}" emake EXTRA_GOFLAGS="${GOFLAGS}" backend
+}
+
+src_install() {
+ dobin gitea
+
+ einstalldocs
+
+ newconfd "${FILESDIR}/gitea.confd-r1" gitea
+ newinitd "${FILESDIR}/gitea.initd-r3" gitea
+ newtmpfiles - gitea.conf <<-EOF
+ d /run/gitea 0755 git git
+ EOF
+ systemd_newunit "${FILESDIR}"/gitea.service-r3 gitea.service
+
+ insinto /etc/gitea
+ newins custom/conf/app.example.ini app.ini
+ if use acct; then
+ fowners root:git /etc/gitea/{,app.ini}
+ fperms g+w,o-rwx /etc/gitea/{,app.ini}
+
+ diropts -m0750 -o git -g git
+ keepdir /var/lib/gitea /var/lib/gitea/custom /var/lib/gitea/data
+ keepdir /var/log/gitea
+ fi
+}
+
+pkg_postinst() {
+ fcaps_pkg_postinst
+ tmpfiles_process gitea.conf
+
+ ewarn "The default JWT signing algorithm changed in 1.15.0 from HS256 (symmetric) to"
+ ewarn "RS256 (asymmetric). Gitea OAuth2 tokens (and potentially client secrets) will"
+ ewarn "need to be regenerated unless you change your JWT_SIGNING_ALGORITHM back to HS256."
+ ewarn "For other breaking changes, see <https://github.com/go-gitea/gitea/releases/tag/v1.15.0>."
+}
diff --git a/www-apps/gitea/metadata.xml b/www-apps/gitea/metadata.xml
index c5a8b29fd81a..0dd2a021ac95 100644
--- a/www-apps/gitea/metadata.xml
+++ b/www-apps/gitea/metadata.xml
@@ -1,11 +1,18 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
- <upstream>
- <remote-id type="github">go-gitea/gitea</remote-id>
- </upstream>
- <use>
- <flag name="acct">User and group management via acct-*/git packages</flag>
- </use>
+ <maintainer type="person" proxied="yes">
+ <name>Thamognya Kodi</name>
+ <email>contact@thamognya.com</email>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">go-gitea/gitea</remote-id>
+ </upstream>
+ <use>
+ <flag name="acct">User and group management via acct-*/git packages</flag>
+ </use>
</pkgmetadata>