summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2024-03-30 18:56:06 -0400
committerMike Pagano <mpagano@gentoo.org>2024-03-30 18:56:06 -0400
commit654f6f738f96c43eda19d96c1b128add2a9fa278 (patch)
tree00e8b7da02c492831e08487ac2d3ee9cb5967b8d /www-apps
parentsys-kernel/linux-docs: drop 6.6.21 (diff)
downloadgentoo-654f6f738f96c43eda19d96c1b128add2a9fa278.tar.gz
gentoo-654f6f738f96c43eda19d96c1b128add2a9fa278.tar.bz2
gentoo-654f6f738f96c43eda19d96c1b128add2a9fa278.zip
www-apps/ttyd: add 1.7.7
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/ttyd/Manifest1
-rw-r--r--www-apps/ttyd/ttyd-1.7.7.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/www-apps/ttyd/Manifest b/www-apps/ttyd/Manifest
index 71c8cb1fc368..0b831bb22551 100644
--- a/www-apps/ttyd/Manifest
+++ b/www-apps/ttyd/Manifest
@@ -1 +1,2 @@
DIST ttyd-1.7.4.tar.gz 603483 BLAKE2B 745ad302fdf17f31d941d3ae4b69b70257f87f3b6d624f3678e83269901577370fc6296726d8b2c61e94469f9970257b1192bcc2299fb0855bd0f3ea5960a498 SHA512 bbaa56389c224db9438b6dcce696deb0eeedfdf9b3a68cbc4c01c155340f71558e1d90c3fabe9a52de180728792b8dc7deed0c3512acdc246d651270d7fb82c6
+DIST ttyd-1.7.7.tar.gz 621347 BLAKE2B 6d6524437fcbde1141c3a256eb1fc21877df1b67586b18053ca05f98202cdd95ac1daf968700e93ff2287b72c93a1195aecf1c424f995c30c619a3b55d3690e4 SHA512 0cc643223c603dfbd32bc8233e6d2b8d59efd0b1208ef684277ff690fd92ca9ce242b8ea229a5621c43301ce99f95ee56fbe1f3b8df47329be89c3d0658d7663
diff --git a/www-apps/ttyd/ttyd-1.7.7.ebuild b/www-apps/ttyd/ttyd-1.7.7.ebuild
new file mode 100644
index 000000000000..3fdbd114e567
--- /dev/null
+++ b/www-apps/ttyd/ttyd-1.7.7.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake systemd
+
+MY_PV="$(ver_rs 3 '-')"
+
+DESCRIPTION="ttyd, a simple command-line tool for sharing terminal over the web"
+HOMEPAGE="https://github.com/tsl0922/ttyd"
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/tsl0922/ttyd.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/tsl0922/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="mbedtls"
+
+DEPEND="
+ dev-libs/json-c:=
+ dev-libs/libuv:=
+ net-libs/libwebsockets:=[libuv,mbedtls=,ssl]
+ sys-libs/zlib:=
+ !mbedtls? ( dev-libs/openssl:= )
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_install() {
+ cmake_src_install
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ systemd_dounit "${FILESDIR}"/${PN}.service
+}