summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authortastytea <gentoo@tastytea.de>2024-07-26 09:10:41 +0200
committerJoonas Niilola <juippis@gentoo.org>2024-08-04 10:03:06 +0300
commitb7c113f035597dc109f13cdb118ceafbade5df0a (patch)
tree11d6720d4a1ffc449199056f9f90f2fb969fcace /www-apps
parentwww-apps/hugo: drop 0.125.7 (diff)
downloadgentoo-b7c113f035597dc109f13cdb118ceafbade5df0a.tar.gz
gentoo-b7c113f035597dc109f13cdb118ceafbade5df0a.tar.bz2
gentoo-b7c113f035597dc109f13cdb118ceafbade5df0a.zip
www-apps/hugo: add check-reqs to 0.129.0
Bug: https://github.com/gentoo/gentoo/pull/37728 Thanks-To: Eli Schwartz <eschwartz@gentoo.org> Signed-off-by: tastytea <gentoo@tastytea.de> Closes: https://github.com/gentoo/gentoo/pull/37635 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/hugo/hugo-0.129.0.ebuild23
1 files changed, 22 insertions, 1 deletions
diff --git a/www-apps/hugo/hugo-0.129.0.ebuild b/www-apps/hugo/hugo-0.129.0.ebuild
index d49c59a1bdb9..e9550f242204 100644
--- a/www-apps/hugo/hugo-0.129.0.ebuild
+++ b/www-apps/hugo/hugo-0.129.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit go-module shell-completion
+inherit check-reqs go-module shell-completion
DESCRIPTION="Fast static HTML and CSS website generator"
HOMEPAGE="https://gohugo.io https://github.com/gohugoio/hugo"
@@ -42,6 +42,27 @@ PATCHES=(
"${FILESDIR}"/${PN}-0.128.0-skip-some-tests.patch
)
+_check_reqs() {
+ if [[ ${MERGE_TYPE} == binary ]] ; then
+ return 0
+ fi
+
+ if has test ${FEATURES}; then
+ CHECKREQS_DISK_BUILD="4G"
+ else
+ CHECKREQS_DISK_BUILD="1500M"
+ fi
+ check-reqs_${EBUILD_PHASE_FUNC}
+}
+
+pkg_pretend() {
+ _check_reqs
+}
+
+pkg_setup() {
+ _check_reqs
+}
+
src_configure() {
export CGO_ENABLED=1
export CGO_CFLAGS="${CFLAGS}"