summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <kangie@gentoo.org>2025-01-29 08:23:21 +1000
committerMatt Jolly <kangie@gentoo.org>2025-01-29 09:26:19 +1000
commit6e1308318aba181f63efe86caf26fc119662f110 (patch)
treec21b254e8ef035f20f17312b3e17757900dfd197 /www-client/chromium
parentwww-client/chromium: drop 133.0.6943.16 (diff)
downloadgentoo-6e1308318aba181f63efe86caf26fc119662f110.tar.gz
gentoo-6e1308318aba181f63efe86caf26fc119662f110.tar.bz2
gentoo-6e1308318aba181f63efe86caf26fc119662f110.zip
www-client/chromium: backport QT5 optional patch to M133
No revbump as it's not worth forcing one over this build-time change (and I expect a new release within 24h). Bug: https://bugs.gentoo.org/926166 Bug: https://bugs.gentoo.org/948836 Signed-off-by: Matt Jolly <kangie@gentoo.org>
Diffstat (limited to 'www-client/chromium')
-rw-r--r--www-client/chromium/chromium-133.0.6943.27.ebuild40
1 files changed, 9 insertions, 31 deletions
diff --git a/www-client/chromium/chromium-133.0.6943.27.ebuild b/www-client/chromium/chromium-133.0.6943.27.ebuild
index eb4824a37752..b86265c53fcb 100644
--- a/www-client/chromium/chromium-133.0.6943.27.ebuild
+++ b/www-client/chromium/chromium-133.0.6943.27.ebuild
@@ -25,7 +25,7 @@ RUST_MIN_VER=1.78.0
RUST_NEEDS_LLVM="yes please"
inherit check-reqs chromium-2 desktop flag-o-matic llvm-r1 multiprocessing ninja-utils pax-utils
-inherit python-any-r1 qmake-utils readme.gentoo-r1 rust systemd toolchain-funcs virtualx xdg-utils
+inherit python-any-r1 readme.gentoo-r1 rust systemd toolchain-funcs virtualx xdg-utils
DESCRIPTION="Open-source version of Google Chrome web browser"
HOMEPAGE="https://www.chromium.org/"
@@ -52,7 +52,7 @@ fi
IUSE_SYSTEM_LIBS="+system-harfbuzz +system-icu +system-png +system-zstd"
IUSE="+X ${IUSE_SYSTEM_LIBS} bindist cups debug ffmpeg-chromium gtk4 +hangouts headless kerberos +official pax-kernel pgo +proprietary-codecs pulseaudio"
-IUSE+=" qt5 qt6 +screencast selinux test +vaapi +wayland +widevine"
+IUSE+=" qt6 +screencast selinux test +vaapi +wayland +widevine"
RESTRICT="
!bindist? ( bindist )
!test? ( test )
@@ -61,7 +61,6 @@ RESTRICT="
REQUIRED_USE="
!headless? ( || ( X wayland ) )
pgo? ( X !wayland )
- qt6? ( qt5 )
screencast? ( wayland )
ffmpeg-chromium? ( bindist proprietary-codecs )
"
@@ -133,10 +132,6 @@ COMMON_DEPEND="
x11-libs/cairo:=
x11-libs/gdk-pixbuf:2
x11-libs/pango:=
- qt5? (
- dev-qt/qtcore:5
- dev-qt/qtwidgets:5
- )
qt6? ( dev-qt/qtbase:6[gui,widgets] )
)
"
@@ -146,7 +141,6 @@ RDEPEND="${COMMON_DEPEND}
x11-libs/gtk+:3[X?,wayland?]
gui-libs/gtk:4[X?,wayland?]
)
- qt5? ( dev-qt/qtgui:5[X?,wayland?] )
qt6? ( dev-qt/qtbase:6[X?,wayland?] )
)
virtual/ttf-fonts
@@ -171,7 +165,6 @@ BDEPEND="
')
>=app-arch/gzip-1.7
!headless? (
- qt5? ( dev-qt/qtcore:5 )
qt6? ( dev-qt/qtbase:6 )
)
$(llvm_gen_dep '
@@ -265,7 +258,7 @@ pkg_pretend() {
fi
if use headless; then
- local headless_unused_flags=("cups" "kerberos" "pulseaudio" "qt5" "qt6" "vaapi" "wayland")
+ local headless_unused_flags=("cups" "kerberos" "pulseaudio" "qt6" "vaapi" "wayland")
for myiuse in ${headless_unused_flags[@]}; do
use ${myiuse} && ewarn "Ignoring USE=${myiuse}, USE=headless is set."
done
@@ -374,6 +367,7 @@ src_prepare() {
"${FILESDIR}/chromium-131-unbundle-icu-target.patch"
"${FILESDIR}/chromium-131-oauth2-client-switches.patch"
"${FILESDIR}/chromium-132-bindgen-custom-toolchain.patch"
+ "${FILESDIR}/chromium-134-qt5-optional.patch"
)
shopt -s globstar nullglob
@@ -1074,7 +1068,9 @@ chromium_configure() {
else
myconf_gn+=" use_system_minigbm=true"
myconf_gn+=" use_xkbcommon=true"
- if use qt5 || use qt6; then
+ myconf_gn+=" use_qt5=false"
+ if use qt6; then
+ myconf_gn+=" use_qt6=true"
local cbuild_libdir=$(get_libdir)
if tc-is-cross-compiler; then
# Hack to workaround get_libdir not being able to handle CBUILD, bug #794181
@@ -1082,21 +1078,9 @@ chromium_configure() {
cbuild_libdir=${cbuild_libdir:2}
cbuild_libdir=${cbuild_libdir/% }
fi
- if use qt5; then
- if tc-is-cross-compiler; then
- myconf_gn+=" moc_qt5_path=\"${EPREFIX}/${cbuild_libdir}/qt5/bin\""
- else
- myconf_gn+=" moc_qt5_path=\"$(qt5_get_bindir)\""
- fi
- fi
- if use qt6; then
- myconf_gn+=" moc_qt6_path=\"${EPREFIX}/usr/${cbuild_libdir}/qt6/libexec\""
- fi
-
- myconf_gn+=" use_qt=true"
- myconf_gn+=" use_qt6=$(usex qt6 true false)"
+ myconf_gn+=" moc_qt6_path=\"${EPREFIX}/usr/${cbuild_libdir}/qt6/libexec\""
else
- myconf_gn+=" use_qt=false"
+ myconf_gn+=" use_qt6=false"
fi
myconf_gn+=" ozone_platform_x11=$(usex X true false)"
myconf_gn+=" ozone_platform_wayland=$(usex wayland true false)"
@@ -1438,12 +1422,6 @@ pkg_postinst() {
elog "behavior you need to pass --gtk-version=4, e.g. by adding it"
elog "to CHROMIUM_FLAGS in /etc/chromium/default."
fi
- if use qt5 && use qt6; then
- elog "Chromium automatically selects Qt5 or Qt6 based on your desktop"
- elog "environment. To override you need to pass --qt-version=5 or"
- elog "--qt-version=6, e.g. by adding it to CHROMIUM_FLAGS in"
- elog "/etc/chromium/default."
- fi
fi
if systemd_is_booted && ! [[ -f "/etc/machine-id" ]]; then