summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-client/luakit/luakit-2012.09.13_p1-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-client/luakit/luakit-2012.09.13_p1-r1.ebuild')
-rw-r--r--www-client/luakit/luakit-2012.09.13_p1-r1.ebuild83
1 files changed, 83 insertions, 0 deletions
diff --git a/www-client/luakit/luakit-2012.09.13_p1-r1.ebuild b/www-client/luakit/luakit-2012.09.13_p1-r1.ebuild
new file mode 100644
index 000000000000..ae17604f88d4
--- /dev/null
+++ b/www-client/luakit/luakit-2012.09.13_p1-r1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit toolchain-funcs
+IUSE="luajit vim-syntax"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/mason-larobina/${PN}.git
+ https://github.com/mason-larobina/${PN}.git"
+ EGIT_BRANCH="develop"
+ KEYWORDS=""
+ SRC_URI=""
+else
+ inherit vcs-snapshot
+ MY_PV="${PV/_p/-r}"
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/mason-larobina/${PN}/tarball/${MY_PV} -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="fast, small, webkit-gtk based micro-browser extensible by lua"
+HOMEPAGE="http://mason-larobina.github.com/luakit/"
+
+LICENSE="GPL-3"
+SLOT="0"
+
+COMMON_DEPEND="
+ luajit? ( dev-lang/luajit:2 )
+ !luajit? ( >=dev-lang/lua-5.1 )
+ dev-db/sqlite:3
+ dev-libs/glib:2
+ dev-libs/libunique:1
+ net-libs/libsoup:2.4
+ net-libs/webkit-gtk:2
+ x11-libs/gtk+:2
+"
+
+DEPEND="
+ virtual/pkgconfig
+ sys-apps/help2man
+ ${COMMON_DEPEND}
+"
+
+RDEPEND="
+ ${COMMON_DEPEND}
+ dev-lua/luafilesystem
+ vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )
+"
+
+src_prepare() {
+ sed -i -e "/^CFLAGS/s/-ggdb//" config.mk || die
+}
+
+src_compile() {
+ myconf="PREFIX=/usr DEVELOPMENT_PATHS=0"
+ if use luajit; then
+ myconf+=" USE_LUAJIT=1"
+ else
+ myconf+=" USE_LUAJIT=0"
+ fi
+
+ if [[ ${PV} != *9999* ]]; then
+ myconf+=" VERSION=${PV}"
+ fi
+
+ tc-export CC
+ emake ${myconf}
+}
+
+src_install() {
+ emake PREFIX="/usr" DESTDIR="${D}" DOCDIR="${D}/usr/share/doc/${PF}" install
+
+ if use vim-syntax; then
+ local t
+ for t in $(ls "${S}"/extras/vim/); do
+ insinto /usr/share/vim/vimfiles/"${t}"
+ doins "${S}"/extras/vim/"${t}"/luakit.vim
+ done
+ fi
+}