summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2022-12-23 23:09:33 +0000
committerJames Le Cuirot <chewi@gentoo.org>2022-12-23 23:09:33 +0000
commit1c62ef9034e22aacc4e0e9838713c98e1ab323af (patch)
tree06336e1a596f291c54529419387f9cd7263559a9 /www-client
parentwww-client/vivaldi-snapshot: Make GTK optional and add Qt5 support (diff)
downloadgentoo-1c62ef9034e22aacc4e0e9838713c98e1ab323af.tar.gz
gentoo-1c62ef9034e22aacc4e0e9838713c98e1ab323af.tar.bz2
gentoo-1c62ef9034e22aacc4e0e9838713c98e1ab323af.zip
www-client/vivaldi: Make GTK optional and add Qt5 support
GTK 3 or 4 is dlopen'd when available, but Vivaldi works fine without either, as it falls back to the "Classic" UI. Qt5 support has now been implemented, although I'm not sure whether it's fully plumbed in yet. I cannot select it in the options, and I don't think it's being used at all. Probably won't be long though. Closes: https://bugs.gentoo.org/887341 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/vivaldi/vivaldi-5.6.2867.50.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/www-client/vivaldi/vivaldi-5.6.2867.50.ebuild b/www-client/vivaldi/vivaldi-5.6.2867.50.ebuild
index 82e87d9746ea..6360223e0294 100644
--- a/www-client/vivaldi/vivaldi-5.6.2867.50.ebuild
+++ b/www-client/vivaldi/vivaldi-5.6.2867.50.ebuild
@@ -107,7 +107,7 @@ RE="\bx86\b"; [[ ${KEYWORDS} =~ ${RE} ]] && SRC_URI+=" x86? ( ${VIVALDI_BASE_URI
LICENSE="Vivaldi"
SLOT="0"
-IUSE="proprietary-codecs widevine"
+IUSE="gtk proprietary-codecs qt5 widevine"
RESTRICT="bindist mirror"
RDEPEND="
@@ -134,8 +134,13 @@ RDEPEND="
x11-libs/libxkbcommon
x11-libs/libXrandr
x11-libs/pango[X]
- || ( gui-libs/gtk:4 x11-libs/gtk+:3 )
+ gtk? ( gui-libs/gtk:4 x11-libs/gtk+:3 )
proprietary-codecs? ( media-video/ffmpeg-chromium:${CHROMIUM_VERSION} )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ )
widevine? ( www-plugins/chrome-binary-plugins )
"
@@ -173,6 +178,10 @@ src_prepare() {
rmdir ${VIVALDI_HOME}/lib || die
fi
+ if ! use qt5; then
+ rm ${VIVALDI_HOME}/libqt5_shim.so || die
+ fi
+
eapply_user
}