summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <kangie@gentoo.org>2024-05-01 12:12:33 +1000
committerMatt Jolly <kangie@gentoo.org>2024-05-01 16:38:02 +1000
commit499e1f68e79d66f7c37f0b27cc01b66198ea3f38 (patch)
treee7931ca564715ae901217f97999f6140d4f5c0d4 /www-client
parentwww-plugins/chrome-binary-plugins: automated update (126.0.6439.0_alpha) (diff)
downloadgentoo-499e1f68e79d66f7c37f0b27cc01b66198ea3f38.tar.gz
gentoo-499e1f68e79d66f7c37f0b27cc01b66198ea3f38.tar.bz2
gentoo-499e1f68e79d66f7c37f0b27cc01b66198ea3f38.zip
www-client/microsoft-edge: automated bump (124.0.2478.67)
Signed-off-by: Matt Jolly <kangie@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/microsoft-edge/Manifest1
-rw-r--r--www-client/microsoft-edge/microsoft-edge-124.0.2478.67.ebuild126
2 files changed, 127 insertions, 0 deletions
diff --git a/www-client/microsoft-edge/Manifest b/www-client/microsoft-edge/Manifest
index 4c2eb3f0bada..30eb48b805f0 100644
--- a/www-client/microsoft-edge/Manifest
+++ b/www-client/microsoft-edge/Manifest
@@ -1 +1,2 @@
DIST microsoft-edge-stable_124.0.2478.51-1_amd64.deb 167565894 BLAKE2B 49f60102da25318f915c90fae6837cb67f5a2500afea900f24c1e9fd219bbdfe728b402094609089302e3b8d78871612518016486f4787c2dcb370bd7c662fe5 SHA512 dde274409293324f5d01b109d6f2cf6878332c563aadf0e2ae499f52d6b9fc54f79cbca82e9553716a8d6f651e2a3d9858637cc19dc1667ed70b61702c87e77e
+DIST microsoft-edge-stable_124.0.2478.67-1_amd64.deb 167526530 BLAKE2B bc2c71b523c303ed1726844156a80a8e245d467c383b53f297882b774679018ae5a7c94dae6290b9597b5d39382ebc4427c96afa45cc89ba2ac993e980dbdc69 SHA512 9264e5901314c965b61e3fa38333722f65f5158e25e237cecb2947ae5a27082f2d72f1f8e7d1d932d39b5a5d4849598ab5aa902639792d682128a589172c0464
diff --git a/www-client/microsoft-edge/microsoft-edge-124.0.2478.67.ebuild b/www-client/microsoft-edge/microsoft-edge-124.0.2478.67.ebuild
new file mode 100644
index 000000000000..0ff710cc5ddc
--- /dev/null
+++ b/www-client/microsoft-edge/microsoft-edge-124.0.2478.67.ebuild
@@ -0,0 +1,126 @@
+# Copyright 2011-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit chromium-2 desktop pax-utils unpacker xdg
+
+DESCRIPTION="The web browser from Microsoft"
+HOMEPAGE="https://www.microsoft.com/edge"
+
+if [[ ${PN} == microsoft-edge ]]; then
+ MY_PN=${PN}-stable
+else
+ MY_PN=${PN}
+fi
+
+MY_P="${MY_PN}_${PV}-1"
+SRC_URI="https://packages.microsoft.com/repos/edge/pool/main/m/${MY_PN}/${MY_P}_amd64.deb"
+S=${WORKDIR}
+
+LICENSE="microsoft-edge"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+IUSE="+mip qt5 qt6"
+RESTRICT="bindist mirror strip"
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ app-misc/ca-certificates
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-fonts/liberation-fonts
+ media-libs/alsa-lib
+ media-libs/mesa[gbm(+)]
+ net-misc/curl[ssl]
+ net-print/cups
+ sys-apps/dbus
+ sys-apps/util-linux
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3[X]
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libxcb
+ x11-libs/libxkbcommon
+ x11-libs/libxshmfence
+ x11-libs/pango
+ x11-misc/xdg-utils
+ mip? ( app-crypt/libsecret )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5[X]
+ dev-qt/qtwidgets:5
+ )
+ qt6? ( dev-qt/qtbase:6[gui,widgets] )
+"
+
+QA_PREBUILT="*"
+QA_DESKTOP_FILE="usr/share/applications/microsoft-edge.*\\.desktop"
+EDGE_HOME="opt/microsoft/msedge${PN#microsoft-edge}"
+
+pkg_nofetch() {
+ eerror "Please wait 24 hours and sync your tree before reporting a bug for microsoft-edge fetch failures."
+}
+
+pkg_pretend() {
+ # Protect against people using autounmask overzealously
+ use amd64 || die "microsoft-edge only works on amd64"
+}
+
+pkg_setup() {
+ chromium_suid_sandbox_check_kernel_config
+}
+
+src_unpack() {
+ :
+}
+
+src_install() {
+ dodir /
+ cd "${ED}" || die
+ unpacker
+
+ rm -f _gpgorigin || die
+
+ rm -r etc usr/share/menu || die
+ mv usr/share/doc/${MY_PN} usr/share/doc/${PF} || die
+
+ gzip -d usr/share/doc/${PF}/changelog.gz || die
+ gzip -d usr/share/man/man1/${MY_PN}.1.gz || die
+ if [[ -L usr/share/man/man1/${PN}.1.gz ]]; then
+ rm usr/share/man/man1/${PN}.1.gz || die
+ dosym ${MY_PN}.1 usr/share/man/man1/${PN}.1
+ fi
+
+ local suffix=
+ [[ ${PN} == microsoft-edge-beta ]] && suffix=_beta
+ [[ ${PN} == microsoft-edge-dev ]] && suffix=_dev
+
+ local size
+ for size in 16 24 32 48 64 128 256 ; do
+ newicon -s ${size} "${EDGE_HOME}/product_logo_${size}${suffix}.png" ${PN}.png
+ done
+
+ if ! use mip; then
+ rm "${EDGE_HOME}"/libmip_{core,protection_sdk}.so || die
+ fi
+
+ if ! use qt5; then
+ rm "${EDGE_HOME}/libqt5_shim.so" || die
+ fi
+ if ! use qt6; then
+ rm "${EDGE_HOME}/libqt6_shim.so" || die
+ fi
+
+ pax-mark m "${EDGE_HOME}/msedge"
+}