summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2023-04-02 10:50:50 -0500
committerJory Pratt <anarchy@gentoo.org>2023-04-02 10:51:38 -0500
commitb7ed580f3e60a06eeb30be7e9cc2fb40432ef7c8 (patch)
treed5e0fced5d532282d2593ca27e69eabf0b56120c /www-client
parentwww-apps/miniflux: stabilize 2.0.42 for amd64, ppc64 (diff)
downloadgentoo-b7ed580f3e60a06eeb30be7e9cc2fb40432ef7c8.tar.gz
gentoo-b7ed580f3e60a06eeb30be7e9cc2fb40432ef7c8.tar.bz2
gentoo-b7ed580f3e60a06eeb30be7e9cc2fb40432ef7c8.zip
www-client/firefox: disable elf-hack for arm64 musl users
Signed-off-by: Jory Pratt <anarchy@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/firefox/firefox-102.9.0.ebuild4
-rw-r--r--www-client/firefox/firefox-111.0.ebuild4
2 files changed, 8 insertions, 0 deletions
diff --git a/www-client/firefox/firefox-102.9.0.ebuild b/www-client/firefox/firefox-102.9.0.ebuild
index 52cb88971193..9bfd33680c83 100644
--- a/www-client/firefox/firefox-102.9.0.ebuild
+++ b/www-client/firefox/firefox-102.9.0.ebuild
@@ -915,6 +915,10 @@ src_configure() {
fi
fi
+ if use elibc_musl && use arm64 ; then
+ mozconfig_add_options_ac 'elf-hack is broken when using musl/arm64' --disable-elf-hack
+ fi
+
# Additional ARCH support
case "${ARCH}" in
arm)
diff --git a/www-client/firefox/firefox-111.0.ebuild b/www-client/firefox/firefox-111.0.ebuild
index f6cac626ceea..4a7b64b5dbd8 100644
--- a/www-client/firefox/firefox-111.0.ebuild
+++ b/www-client/firefox/firefox-111.0.ebuild
@@ -1009,6 +1009,10 @@ src_configure() {
fi
fi
+ if use elibc_musl && use arm64 ; then
+ mozconfig_add_options_ac 'elf-hack is broken when using musl/arm64' --disable-elf-hack
+ fi
+
# Additional ARCH support
case "${ARCH}" in
arm)