summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-04-11 18:21:44 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-04-11 18:21:51 +0300
commitad951806687f2db71d754d9b027a028d89de1c1e (patch)
treeacb2b1b4ffcd932ec8c647f81578013474e1d026 /www-misc/profile-sync-daemon
parentapp-i18n/kanjipad: EAPI8, add missing RDEPs (diff)
downloadgentoo-ad951806687f2db71d754d9b027a028d89de1c1e.tar.gz
gentoo-ad951806687f2db71d754d9b027a028d89de1c1e.tar.bz2
gentoo-ad951806687f2db71d754d9b027a028d89de1c1e.zip
www-misc/profile-sync-daemon: add 6.50, EAPI8
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'www-misc/profile-sync-daemon')
-rw-r--r--www-misc/profile-sync-daemon/Manifest1
-rw-r--r--www-misc/profile-sync-daemon/profile-sync-daemon-6.50.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/www-misc/profile-sync-daemon/Manifest b/www-misc/profile-sync-daemon/Manifest
index 9033beace7b0..068b036884c6 100644
--- a/www-misc/profile-sync-daemon/Manifest
+++ b/www-misc/profile-sync-daemon/Manifest
@@ -1,3 +1,4 @@
DIST profile-sync-daemon-5.75.tar.gz 27829 BLAKE2B b333688af27a7373f72e72a09dd18afc210f2196957a76f6fab59d46ecd4e9b905b833a66bf49001c0be307b05b06320d7ee2b754cee1b6559a113346717b82b SHA512 54c2a6c743bf3a3dd746862f6dc0448c8993c96fe0163f4f89885cee3e4c81ecac46414c0ca57d57ec0e9e6c646f9a39462d5d533a7515a952cc56276509bdc0
DIST profile-sync-daemon-6.31.tar.gz 20490 BLAKE2B 6c65f414230051e71578d1d0d69dd266a6d2b6f741b9c3a0e6b3132945fbe8f98db12544ac145609c82e793e1a8d5e8cef278191e653cb5560c3451d6f158307 SHA512 7e7585e902c2428c28dc980c73ebf77ea7f2b39133a6ad0c82e714c2789811c42785ac5d403f965f1b3de8c685d7cba51810ea99206e2b7351dbd607a2cd0fdb
DIST profile-sync-daemon-6.35.tar.gz 20578 BLAKE2B f989682396f1423acf26719b74a356b0ee3933571aaf6a757620504392083d36bce278cfe9e0bb7a81dd1a95d51454c7bb039a556ce3670ce6b75b0c18e2bcea SHA512 e406d39c4edeabc8baa45320a97656791d4099cc8db84aac2cb9f72ef2ed034c82bba73d53457f4ae4201c945af106717d2d979df5a3f154e307f2e6cc41411a
+DIST profile-sync-daemon-6.50.tar.gz 21464 BLAKE2B 8a16fdd102fd96acef9b777c9a4ca23a0d8b2f8e40e222acc85fe2f2a2734030b1cddd866905cb63d0b29ba7f5e0268d6f4987a88a6f7a7628b23338729802a1 SHA512 e98f3d0d4970016459560119547f6b769c4a159c0f75530124b799ed51b7f08ba384a372bb64b9f06bbb64740638059c1a2b4a061ea92589fbbdf601ed279c05
diff --git a/www-misc/profile-sync-daemon/profile-sync-daemon-6.50.ebuild b/www-misc/profile-sync-daemon/profile-sync-daemon-6.50.ebuild
new file mode 100644
index 000000000000..d8a33596e6ea
--- /dev/null
+++ b/www-misc/profile-sync-daemon/profile-sync-daemon-6.50.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Symlinks and syncs browser profile dirs to RAM"
+HOMEPAGE="https://wiki.archlinux.org/title/Profile-sync-daemon"
+SRC_URI="https://github.com/graysky2/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-shells/bash
+ net-misc/rsync[xattr]
+ sys-apps/systemd
+"
+
+src_install() {
+ emake DESTDIR="${D}" COMPRESS_MAN=0 install
+}
+
+pkg_postinst() {
+ local replacing
+ for replacing in ${REPLACING_VERSIONS}; do
+ if [[ $(ver_cut 1 "${replacing}") -eq 5 ]]; then
+ ewarn "${PN}-6 and later dropped OpenRC and /etc/psd.conf support"
+ ewarn "See https://github.com/graysky2/profile-sync-daemon#note-for-version-6"
+ break
+ fi
+ done
+}