summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarri Nieminen <moikkis@gmail.com>2017-12-03 18:25:55 +0200
committerMichael Palimaka <kensington@gentoo.org>2017-12-06 23:28:36 +1100
commitb99d3eb3e5d017e7812e0605c28beeb800d99619 (patch)
tree8abe6202fee934b19f0de4afd1ed6337167a236b /www-servers/fnord/fnord-1.11-r1.ebuild
parentapp-editors/gummi: Minor changes. (diff)
downloadgentoo-b99d3eb3e5d017e7812e0605c28beeb800d99619.tar.gz
gentoo-b99d3eb3e5d017e7812e0605c28beeb800d99619.tar.bz2
gentoo-b99d3eb3e5d017e7812e0605c28beeb800d99619.zip
www-servers/fnord: EAPI 3 -> 6
Closes: https://github.com/gentoo/gentoo/pull/6427 Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'www-servers/fnord/fnord-1.11-r1.ebuild')
-rw-r--r--www-servers/fnord/fnord-1.11-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/www-servers/fnord/fnord-1.11-r1.ebuild b/www-servers/fnord/fnord-1.11-r1.ebuild
new file mode 100644
index 000000000000..d758fdc2ba56
--- /dev/null
+++ b/www-servers/fnord/fnord-1.11-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic toolchain-funcs user
+
+DESCRIPTION="Yet another small httpd"
+HOMEPAGE="http://www.fefe.de/fnord/"
+SRC_URI="http://www.fefe.de/fnord/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="auth"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ virtual/daemontools
+ sys-apps/ucspi-tcp"
+
+DOCS=( TODO README README.auth SPEED CHANGES )
+PATCHES=( "${FILESDIR}/${PN}"-1.10-gentoo.diff )
+
+pkg_setup() {
+ enewgroup nofiles 200
+ enewuser fnord -1 -1 /etc/fnord nofiles
+ enewuser fnordlog -1 -1 /etc/fnord nofiles
+}
+
+src_compile() {
+ # Fix for bug #45716
+ use sparc && replace-sparc64-flags
+
+ use auth && append-flags -DAUTH
+
+ emake DIET="" CC=$(tc-getCC) CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install () {
+ dobin fnord-conf fnord
+ einstalldocs
+}