summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-05-15 23:03:13 -0400
committerMatt Turner <mattst88@gentoo.org>2023-05-15 23:04:18 -0400
commitf9c9f710eee7536b88f9620849a8704e46c7b605 (patch)
treee70ca3474b486572fc7c3abcd9e73ae4ba4e3866 /x11-apps/setxkbmap
parentsys-libs/talloc: add Valgrind annotation support (diff)
downloadgentoo-f9c9f710eee7536b88f9620849a8704e46c7b605.tar.gz
gentoo-f9c9f710eee7536b88f9620849a8704e46c7b605.tar.bz2
gentoo-f9c9f710eee7536b88f9620849a8704e46c7b605.zip
x11-apps/setxkbmap: Version bump to 1.3.4
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-apps/setxkbmap')
-rw-r--r--x11-apps/setxkbmap/Manifest1
-rw-r--r--x11-apps/setxkbmap/setxkbmap-1.3.4.ebuild19
2 files changed, 20 insertions, 0 deletions
diff --git a/x11-apps/setxkbmap/Manifest b/x11-apps/setxkbmap/Manifest
index 44983976a49f..cb6b3fd33a62 100644
--- a/x11-apps/setxkbmap/Manifest
+++ b/x11-apps/setxkbmap/Manifest
@@ -1 +1,2 @@
DIST setxkbmap-1.3.3.tar.xz 130416 BLAKE2B 34ea39054a4e03e5d33778b993afbc0356f898ed45eb9d182fc589a75c92a63275f9c49abbf18b637d83acb9a2f9609794253f3f38f814dbbea741987ddc72ba SHA512 208f07a7f7bce47b573099d4cd8c941a3a4d74b456720bc3ca1cbba298381a2ab98c7500d6e6cd6d5dd61840b7c42cf6521da754ec395f266f8158102a55ad58
+DIST setxkbmap-1.3.4.tar.xz 132300 BLAKE2B 693f910efcd6f4cb26abd59f6197d77fc958e2b21ab4525e095d966a80186ad95792143ea25cf2822436b57838efbcb66c700ecf8341f3eb6ebce0f636760f37 SHA512 f4d026e7707656173f54d79b95ff3370ae06eaf252b89b79bc7175edeaf3ef79073d4d7d8a35fdee95608bf85d7d23514d74f00e55b613810ef6c3ccc0cf498b
diff --git a/x11-apps/setxkbmap/setxkbmap-1.3.4.ebuild b/x11-apps/setxkbmap/setxkbmap-1.3.4.ebuild
new file mode 100644
index 000000000000..9585e8f08f76
--- /dev/null
+++ b/x11-apps/setxkbmap/setxkbmap-1.3.4.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3
+
+DESCRIPTION="Controls the keyboard layout of a running X server"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+COMMON_DEPEND="
+ x11-libs/libxkbfile
+ x11-libs/libX11
+ x11-libs/libXrandr"
+DEPEND="${COMMON_DEPEND}
+ x11-base/xorg-proto"
+RDEPEND="${COMMON_DEPEND}
+ x11-misc/xkeyboard-config"