summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2018-06-18 22:03:51 -0700
committerMatt Turner <mattst88@gentoo.org>2018-06-18 22:07:53 -0700
commita1d998b88ecbd6726b574e5df711779c964f5769 (patch)
tree50dfb4d0f9775721841b5de15e1a0777caa0e3b6 /x11-libs/libXaw3d
parentsys-cluster/neutron: 11.0.5 bup (diff)
downloadgentoo-a1d998b88ecbd6726b574e5df711779c964f5769.tar.gz
gentoo-a1d998b88ecbd6726b574e5df711779c964f5769.tar.bz2
gentoo-a1d998b88ecbd6726b574e5df711779c964f5769.zip
x11-libs/libXaw3d: Version bump 1.6.3
Also add xpm USE flag. Closes: https://bugs.gentoo.org/636766
Diffstat (limited to 'x11-libs/libXaw3d')
-rw-r--r--x11-libs/libXaw3d/Manifest1
-rw-r--r--x11-libs/libXaw3d/libXaw3d-1.6.3.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/x11-libs/libXaw3d/Manifest b/x11-libs/libXaw3d/Manifest
index 5d7bd6c055d4..19b6473e7e56 100644
--- a/x11-libs/libXaw3d/Manifest
+++ b/x11-libs/libXaw3d/Manifest
@@ -1 +1,2 @@
DIST libXaw3d-1.6.2.tar.bz2 551851 BLAKE2B 13a03eba7af518fcaa33e89e0cf7c0955c175866348d314210f15a291590fdea98e1b5b9628252932826069bb3a3e89b2377dd80f1adfe3a2bb06e6f82f85408 SHA512 11b15884e47efc139aa019f0a76086913535767fb2e20fcd837d810d3b6b4a7bda3408be5fa0cbe90ae16eeaebe5db9b0ec77a0e2b5767590662ef3a7c9c96ea
+DIST libXaw3d-1.6.3.tar.bz2 561594 BLAKE2B 85f3fb6d39a9a0ccb7d2c529eff84a4a9e85bf81be16487f2119da0a670e40c2d328e17b06ca237f69029e8d43daf6eeba8488029e6e4d2f56bc1093a2f305ad SHA512 f79f997ff8442563c74f38c7d76fab2c9253691743ca3143047ce698adb4c126d02dc968be7bdc79ab3052b785fd705375d2f01171e3a3266736beb531c91424
diff --git a/x11-libs/libXaw3d/libXaw3d-1.6.3.ebuild b/x11-libs/libXaw3d/libXaw3d-1.6.3.ebuild
new file mode 100644
index 000000000000..b92be978bab7
--- /dev/null
+++ b/x11-libs/libXaw3d/libXaw3d-1.6.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit xorg-2
+
+DESCRIPTION="X.Org Xaw3d library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="unicode xpm"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXt"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ virtual/yacc
+ x11-base/xorg-proto"
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable unicode internationalization)
+ $(use_enable xpm multiplane-bitmaps)
+ --enable-arrow-scrollbars
+ --enable-gray-stipples
+ )
+
+ xorg-2_pkg_setup
+}