summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-04-15 23:18:43 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-04-15 23:18:57 +0200
commit990baa9260f72cad312523eb8f5f8089cdefcfc2 (patch)
treefecaa32a0f31de26bfa7d9219ab474bc9dd79bcc /x11-libs/libnotify/libnotify-0.7.8.ebuild
parentdev-python/setuptools: arm64 keyworded (bug #676560) (diff)
downloadgentoo-990baa9260f72cad312523eb8f5f8089cdefcfc2.tar.gz
gentoo-990baa9260f72cad312523eb8f5f8089cdefcfc2.tar.bz2
gentoo-990baa9260f72cad312523eb8f5f8089cdefcfc2.zip
x11-libs/libnotify: Bump to version 0.7.8
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'x11-libs/libnotify/libnotify-0.7.8.ebuild')
-rw-r--r--x11-libs/libnotify/libnotify-0.7.8.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/x11-libs/libnotify/libnotify-0.7.8.ebuild b/x11-libs/libnotify/libnotify-0.7.8.ebuild
new file mode 100644
index 000000000000..ff9add88c106
--- /dev/null
+++ b/x11-libs/libnotify/libnotify-0.7.8.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org meson multilib-minimal xdg-utils
+
+DESCRIPTION="A library for sending desktop notifications"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/libnotify"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="+introspection test"
+
+RDEPEND="
+ app-eselect/eselect-notify-send
+ >=dev-libs/glib-2.26:2[${MULTILIB_USEDEP}]
+ x11-libs/gdk-pixbuf:2[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-1.32:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=dev-libs/gobject-introspection-common-1.32
+ dev-util/glib-utils
+ virtual/pkgconfig
+ test? ( x11-libs/gtk+:3[${MULTILIB_USEDEP}] )
+"
+PDEPEND="virtual/notification-daemon"
+
+src_prepare() {
+ default
+ xdg_environment_reset
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dtests="$(usex test true false)"
+ -Dintrospection="$(multilib_native_usex introspection enabled disabled)"
+ -Dgtk_doc=false
+ -Ddocbook_docs=disabled
+ )
+ meson_src_configure
+}
+
+multilib_src_install() {
+ meson_src_install
+
+ mv "${ED}"/usr/bin/{,libnotify-}notify-send || die #379941
+}
+
+pkg_postinst() {
+ eselect notify-send update ifunset
+}
+
+pkg_postrm() {
+ eselect notify-send update ifunset
+}