summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-libs/libtinynotify-systemwide
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-libs/libtinynotify-systemwide')
-rw-r--r--x11-libs/libtinynotify-systemwide/Manifest2
-rw-r--r--x11-libs/libtinynotify-systemwide/libtinynotify-systemwide-0.0.2.ebuild32
-rw-r--r--x11-libs/libtinynotify-systemwide/libtinynotify-systemwide-0.1.ebuild30
-rw-r--r--x11-libs/libtinynotify-systemwide/libtinynotify-systemwide-9999.ebuild44
-rw-r--r--x11-libs/libtinynotify-systemwide/metadata.xml16
5 files changed, 124 insertions, 0 deletions
diff --git a/x11-libs/libtinynotify-systemwide/Manifest b/x11-libs/libtinynotify-systemwide/Manifest
new file mode 100644
index 000000000000..83447133c2a7
--- /dev/null
+++ b/x11-libs/libtinynotify-systemwide/Manifest
@@ -0,0 +1,2 @@
+DIST libtinynotify-systemwide-0.0.2.tar.bz2 256779 SHA256 7f4fac8333d7e3318977387ce8deb6f67c548f467a5e33dc5c082fc0206456a9 SHA512 54d8c0c409815d3aa29d6141d40ca734edb3e85e5b8541401fc4d180087d3b56b16e84ba8652bf6701f8f8755e7c85ee77d0ac082d2732325a8459fb71980bb0 WHIRLPOOL a000f32f5859ca4fb34f3ca07cb5665ebbb52236b94525b65a24afdce0634f882585f2f0cd35e70be383119dcc9485987dbff2fee8ff4a9144d5727f26b0c7e3
+DIST libtinynotify-systemwide-0.1.tar.bz2 270071 SHA256 ae2c3bb845eec3eae8921b7887f0cbbc9f468012020c2d6e2c18e30f8d858217 SHA512 95516208485ed46e4702806bca467af509b9756a738f5f345cec712d878f14f4d9c84b78c33f0e4a41e0bf7be3b6e8e50dcd230da753c2827ae75793ca1c74aa WHIRLPOOL 4d40e217ddd44e64e45bcd47f7d0c0f59e7d3c545cd3f921bcec1f2697dd26ce8f2a2633b1382509616cbbb8402f47632b7b205f6820eee86e13002461b51bf9
diff --git a/x11-libs/libtinynotify-systemwide/libtinynotify-systemwide-0.0.2.ebuild b/x11-libs/libtinynotify-systemwide/libtinynotify-systemwide-0.0.2.ebuild
new file mode 100644
index 000000000000..8d332592b991
--- /dev/null
+++ b/x11-libs/libtinynotify-systemwide/libtinynotify-systemwide-0.0.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools-utils
+
+DESCRIPTION="A system-wide notifications module for libtinynotify"
+HOMEPAGE="https://github.com/mgorny/libtinynotify-systemwide/"
+SRC_URI="mirror://github/mgorny/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc static-libs"
+
+RDEPEND="sys-process/procps
+ x11-libs/libtinynotify"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( dev-util/gtk-doc )"
+
+DOCS=( README )
+
+src_configure() {
+ myeconfargs=(
+ $(use_enable doc gtk-doc)
+ )
+
+ autotools-utils_src_configure
+}
diff --git a/x11-libs/libtinynotify-systemwide/libtinynotify-systemwide-0.1.ebuild b/x11-libs/libtinynotify-systemwide/libtinynotify-systemwide-0.1.ebuild
new file mode 100644
index 000000000000..cc2b738428ff
--- /dev/null
+++ b/x11-libs/libtinynotify-systemwide/libtinynotify-systemwide-0.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools-utils
+
+DESCRIPTION="A system-wide notifications module for libtinynotify"
+HOMEPAGE="https://bitbucket.org/mgorny/libtinynotify-systemwide/"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc static-libs"
+
+RDEPEND="sys-process/procps
+ x11-libs/libtinynotify"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( dev-util/gtk-doc )"
+
+src_configure() {
+ myeconfargs=(
+ $(use_enable doc gtk-doc)
+ )
+
+ autotools-utils_src_configure
+}
diff --git a/x11-libs/libtinynotify-systemwide/libtinynotify-systemwide-9999.ebuild b/x11-libs/libtinynotify-systemwide/libtinynotify-systemwide-9999.ebuild
new file mode 100644
index 000000000000..5e70291e17ae
--- /dev/null
+++ b/x11-libs/libtinynotify-systemwide/libtinynotify-systemwide-9999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+#if LIVE
+AUTOTOOLS_AUTORECONF=yes
+EGIT_REPO_URI="http://bitbucket.org/mgorny/${PN}.git"
+
+inherit git-r3
+#endif
+
+inherit autotools-utils
+
+DESCRIPTION="A system-wide notifications module for libtinynotify"
+HOMEPAGE="https://bitbucket.org/mgorny/libtinynotify-systemwide/"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc static-libs"
+
+RDEPEND="sys-process/procps:0=
+ x11-libs/libtinynotify:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( dev-util/gtk-doc )"
+
+#if LIVE
+KEYWORDS=
+SRC_URI=
+DEPEND="${DEPEND}
+ >=dev-util/gtk-doc-1.18"
+#endif
+
+src_configure() {
+ myeconfargs=(
+ $(use_enable doc gtk-doc)
+ )
+
+ autotools-utils_src_configure
+}
diff --git a/x11-libs/libtinynotify-systemwide/metadata.xml b/x11-libs/libtinynotify-systemwide/metadata.xml
new file mode 100644
index 000000000000..26adff3f76af
--- /dev/null
+++ b/x11-libs/libtinynotify-systemwide/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <upstream>
+ <maintainer status="active">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <bugs-to>https://bitbucket.org/mgorny/libtinynotify-systemwide/issues/</bugs-to>
+ <remote-id type="bitbucket">mgorny/libtinynotify-systemwide</remote-id>
+ </upstream>
+</pkgmetadata>