summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-11-22 16:12:43 -0500
committerMatt Turner <mattst88@gentoo.org>2020-11-22 16:15:59 -0500
commit0196099bb7b8b36e2586027d60999222c937772f (patch)
tree051c553676c75bf762651910ea2dbccec0d09a4b /x11-libs/libxkbcommon
parentx11-libs/libX11: Version bump to 1.7.0 (diff)
downloadgentoo-0196099bb7b8b36e2586027d60999222c937772f.tar.gz
gentoo-0196099bb7b8b36e2586027d60999222c937772f.tar.bz2
gentoo-0196099bb7b8b36e2586027d60999222c937772f.zip
x11-libs/libxkbcommon: Version bump to 1.0.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs/libxkbcommon')
-rw-r--r--x11-libs/libxkbcommon/Manifest1
-rw-r--r--x11-libs/libxkbcommon/libxkbcommon-1.0.2.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/x11-libs/libxkbcommon/Manifest b/x11-libs/libxkbcommon/Manifest
index e7524f531f6b..e97bd6d237ca 100644
--- a/x11-libs/libxkbcommon/Manifest
+++ b/x11-libs/libxkbcommon/Manifest
@@ -1,2 +1,3 @@
DIST libxkbcommon-0.10.0.tar.xz 383788 BLAKE2B 0e2cc110c35a4d07cfd55a46a4cc30038bc296f74522beb97b72d0318799adb76fa514427640f286254de7aa59fb8b8c26de5d8fd52f7e09c5ba3521febb97bd SHA512 58c523b42a8ea0cae7322d453fbc5d4624374221246cb067074e2ff9820eef3ceea8686283136432cdf0842acfc0858c7b2d3954de234b6501092ae1d27c9e79
DIST libxkbcommon-1.0.1.tar.xz 432692 BLAKE2B 151e9c2260b517e7e646defea8dfa1891af87aaeeebbf52d41d8e6b52c2c1d5079ca55da9e998300145c83718ce981be13c3fa35d8825bcde7846dcd330e9dfd SHA512 929be7b52fae360a696f01e0a8f3aa9b585ad99db975a88680ababf623e46f4d98e6f7590a2859c24060856f45b27e7249072702fbbf5a7bd0d4a10791e6d489
+DIST libxkbcommon-1.0.2.tar.xz 433648 BLAKE2B 6e5632bc00656913c76f4be216ebe7869f424ea1f5c083ca941c2e515cc4ad1afef7827725859bf64d298ee7277afc36fb69b2007be92cd5f5a399190cc04745 SHA512 d3db99ea5c8dd55ee6c8f4b3b6ba4586bb4b2be1504e88174e026593f7762a83c68b1ea06fae859668e3a95f91dc3b9f308af910ceaf2e1bcbd06e82e8fc3e66
diff --git a/x11-libs/libxkbcommon/libxkbcommon-1.0.2.ebuild b/x11-libs/libxkbcommon/libxkbcommon-1.0.2.ebuild
new file mode 100644
index 000000000000..29174e983b21
--- /dev/null
+++ b/x11-libs/libxkbcommon/libxkbcommon-1.0.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} = *9999* ]]; then
+ GIT_ECLASS="git-r3"
+ EGIT_REPO_URI="https://github.com/xkbcommon/${PN}"
+else
+ SRC_URI="https://xkbcommon.org/download/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+fi
+
+inherit meson multilib-minimal ${GIT_ECLASS}
+
+DESCRIPTION="keymap handling library for toolkits and window systems"
+HOMEPAGE="https://xkbcommon.org/ https://github.com/xkbcommon/libxkbcommon/"
+LICENSE="MIT"
+IUSE="X doc static-libs test"
+RESTRICT="!test? ( test )"
+SLOT="0"
+
+BDEPEND="
+ sys-devel/bison
+ doc? ( app-doc/doxygen )"
+RDEPEND="
+ X? ( >=x11-libs/libxcb-1.10:=[${MULTILIB_USEDEP},xkb] )
+ dev-libs/libxml2[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Ddefault_library="$(usex static-libs both shared)"
+ -Dxkb-config-root="${EPREFIX}/usr/share/X11/xkb"
+ -Denable-wayland=false # Demo applications
+ $(meson_use X enable-x11)
+ $(meson_use doc enable-docs)
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_test() {
+ meson_src_test
+}
+
+multilib_src_install() {
+ meson_src_install
+}