summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-10-09 10:57:06 -0700
committerMatt Turner <mattst88@gentoo.org>2019-10-09 10:57:20 -0700
commit14bd6ea9f76685de7929735a79aefe31c4fce34c (patch)
treeca14d25345e35205ee32ee25a7386e9b72aeb596 /x11-libs
parentmedia-libs/mesa: Version bump to 19.2.1 (diff)
downloadgentoo-14bd6ea9f76685de7929735a79aefe31c4fce34c.tar.gz
gentoo-14bd6ea9f76685de7929735a79aefe31c4fce34c.tar.bz2
gentoo-14bd6ea9f76685de7929735a79aefe31c4fce34c.zip
x11-libs/libX11: Version bump to 1.6.9
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libX11/Manifest1
-rw-r--r--x11-libs/libX11/libX11-1.6.9.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/x11-libs/libX11/Manifest b/x11-libs/libX11/Manifest
index 5a16ca0b8a13..8ee0e1ff8c06 100644
--- a/x11-libs/libX11/Manifest
+++ b/x11-libs/libX11/Manifest
@@ -1 +1,2 @@
DIST libX11-1.6.8.tar.bz2 2395911 BLAKE2B 50f8871d7ff2aee14767085a6cf78e9f6e2b01c5143227089590c86db8006836432cb051d6259893850d78d2daea3332a26885a34f07989b869c14b8ddeefa28 SHA512 1de8e0ec466308bc48946d1ce7a7dc6bd3120b1b365cd01afd1bd51dd7369e3d1870dd379b0b7c5b07699095d59761bd23e2e02ab60929de32c39b6885016e76
+DIST libX11-1.6.9.tar.bz2 2283814 BLAKE2B 00fb965b9cd19bde79c4e598c677d21058c85a8ac37d9addab7fb0b2faf67e3d65b91e1864bcd7180e5fd8b0ab7ec3cf68ae7f95ac8e82a049529b5a139b43bd SHA512 fc18f0dc17ade1fc37402179f52e1f2b9c7b7d3a1a9590fea13046eb0c5193b4796289431cd99388eac01e8e59de77db45d2c9675d4f05ef8cf3ba6382c3dd31
diff --git a/x11-libs/libX11/libX11-1.6.9.ebuild b/x11-libs/libX11/libX11-1.6.9.ebuild
new file mode 100644
index 000000000000..6cd68250158f
--- /dev/null
+++ b/x11-libs/libX11/libX11-1.6.9.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+inherit xorg-3
+
+DESCRIPTION="X.Org X11 library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="ipv6 test"
+
+RDEPEND=">=x11-libs/libxcb-1.11.1[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ x11-libs/xtrans"
+BDEPEND="test? ( dev-lang/perl )"
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_with doc xmlto)
+ $(use_enable doc specs)
+ $(use_enable ipv6)
+ --without-fop
+ )
+}