summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Dawson <matthew@mjdsystems.ca>2016-12-12 18:08:59 -0500
committerDavid Seifert <soap@gentoo.org>2017-01-04 14:34:32 +0200
commit4d32a2332e5d4a6cb8e879be5f621e6bbb9123e4 (patch)
treef45d8a03f71fe8790e0e8aa9c8c3f2bd84b85d9d /x11-libs
parentdev-python/neovim-python-client: Bump to 0.1.12 (diff)
downloadgentoo-4d32a2332e5d4a6cb8e879be5f621e6bbb9123e4.tar.gz
gentoo-4d32a2332e5d4a6cb8e879be5f621e6bbb9123e4.tar.bz2
gentoo-4d32a2332e5d4a6cb8e879be5f621e6bbb9123e4.zip
x11-libs/libqxt: Add gcc 6 patch
Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/3102
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libqxt/files/libqxt-gcc6-fix.patch12
-rw-r--r--x11-libs/libqxt/libqxt-0.6.2-r2.ebuild3
2 files changed, 14 insertions, 1 deletions
diff --git a/x11-libs/libqxt/files/libqxt-gcc6-fix.patch b/x11-libs/libqxt/files/libqxt-gcc6-fix.patch
new file mode 100644
index 000000000000..23adc1dca78f
--- /dev/null
+++ b/x11-libs/libqxt/files/libqxt-gcc6-fix.patch
@@ -0,0 +1,12 @@
+diff -ru libqxt-libqxt-v0.6.2/src/core/qxtslotjob.cpp libqxt-libqxt-v0.6.2.new/src/core/qxtslotjob.cpp
+--- libqxt-libqxt-v0.6.2/src/core/qxtslotjob.cpp 2011-11-24 17:10:32.000000000 -0500
++++ libqxt-libqxt-v0.6.2.new/src/core/qxtslotjob.cpp 2016-12-08 18:07:07.460538282 -0500
+@@ -174,7 +174,7 @@
+
+ QVariant QxtFuture::delayedResult(int msec)
+ {
+- if (!waiter->wait(msec, false))
++ if (!waiter->wait(msec, QEventLoop::AllEvents))
+ return QVariant();
+ return job->result();
+ }
diff --git a/x11-libs/libqxt/libqxt-0.6.2-r2.ebuild b/x11-libs/libqxt/libqxt-0.6.2-r2.ebuild
index 929e3887a5d6..9165ff39e3ac 100644
--- a/x11-libs/libqxt/libqxt-0.6.2-r2.ebuild
+++ b/x11-libs/libqxt/libqxt-0.6.2-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -39,6 +39,7 @@ PATCHES=(
"${FILESDIR}/${PN}-invoke-prev-filter.patch" # bug 494448
"${FILESDIR}/${PN}-media-keys.patch" # bug 495984
"${FILESDIR}/${PN}-xrandr-missing-lib.patch"
+ "${FILESDIR}/${PN}-gcc6-fix.patch"
)
src_prepare() {