summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-11-24 04:17:17 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-11-24 05:53:26 -0500
commit59ca1a557374ce1e1e6b5386393d93eee95e741f (patch)
tree73a6e34908fa0b15060a2d6e660f0a58dec6055d /x11-misc/devilspie
parentx11-misc/mygestures: pass -std=gnu17 for gcc15 (diff)
downloadgentoo-59ca1a557374ce1e1e6b5386393d93eee95e741f.tar.gz
gentoo-59ca1a557374ce1e1e6b5386393d93eee95e741f.tar.bz2
gentoo-59ca1a557374ce1e1e6b5386393d93eee95e741f.zip
x11-misc/devilspie: pass -std=gnu17 for gcc15
May be an easy fix, but there's been no releases since 2012 and if there's been commits I don't know where they're happening. It's not worth keeping a (probably) permanent patch over. devilspie2 (w/ a semi-active different upstream) can act as a replacement if need be, albeit this one uses different configuration that some may prefer and no reason to last-rite over trivial issues. Closes: https://bugs.gentoo.org/944096 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-misc/devilspie')
-rw-r--r--x11-misc/devilspie/devilspie-0.23-r2.ebuild15
1 files changed, 11 insertions, 4 deletions
diff --git a/x11-misc/devilspie/devilspie-0.23-r2.ebuild b/x11-misc/devilspie/devilspie-0.23-r2.ebuild
index 985daf2b245f..60f3341f146f 100644
--- a/x11-misc/devilspie/devilspie-0.23-r2.ebuild
+++ b/x11-misc/devilspie/devilspie-0.23-r2.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+inherit flag-o-matic
+
DESCRIPTION="Window matching utility similar to Sawfish's Matched Windows"
HOMEPAGE="https://www.burtonini.com/blog/tag/devilspie.html"
SRC_URI="https://www.burtonini.com/computing/${P}.tar.xz"
@@ -15,16 +17,21 @@ RDEPEND="
dev-libs/glib:2
x11-libs/gtk+:3[X]
x11-libs/libX11
- x11-libs/libwnck:3"
+ x11-libs/libwnck:3
+"
DEPEND="
${RDEPEND}
- x11-base/xorg-proto"
+ x11-base/xorg-proto
+"
BDEPEND="
dev-util/intltool
- virtual/pkgconfig"
+ virtual/pkgconfig
+"
src_prepare() {
default
sed -i "/doc\//s@devilspie..@${PF}/@" devilspie.1 || die
+
+ append-cflags -std=gnu17 #944096
}