summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-07-27 18:37:19 -0500
committerMatt Turner <mattst88@gentoo.org>2018-07-27 17:38:26 -0700
commit64cc98700d9c66ec4e843119a49e4714e4dd6e13 (patch)
tree752869c86790c0c7072cce7b51c246a03f5980b2 /x11-misc/imake
parentx11-misc/imake: port to EAPI 7 (diff)
downloadgentoo-64cc98700d9c66ec4e843119a49e4714e4dd6e13.tar.gz
gentoo-64cc98700d9c66ec4e843119a49e4714e4dd6e13.tar.bz2
gentoo-64cc98700d9c66ec4e843119a49e4714e4dd6e13.zip
x11-misc/imake: add live ebuild
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'x11-misc/imake')
-rw-r--r--x11-misc/imake/imake-9999.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/x11-misc/imake/imake-9999.ebuild b/x11-misc/imake/imake-9999.ebuild
new file mode 100644
index 000000000000..a4ee1f9952ca
--- /dev/null
+++ b/x11-misc/imake/imake-9999.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="C preprocessor interface to the make utility"
+HOMEPAGE="https://www.x.org/wiki/ https://cgit.freedesktop.org/"
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/xorg/util/imake.git"
+ inherit autotools git-r3
+ # x11-misc-util/macros only required on live ebuilds
+ LIVE_DEPEND=">=x11-misc/util-macros-1.18"
+else
+ SRC_URI="mirror://xorg/util/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+BDEPEND="
+ virtual/pkgconfig
+"
+RDEPEND="
+ x11-misc/xorg-cf-files
+"
+DEPEND="
+ ${LIVE_DEPEND}
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+
+PATCHES=(
+ # don't use Sun compilers on Solaris, we want GCC from prefix
+ "${FILESDIR}"/${PN}-1.0.7-sun-compiler.patch
+)
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ local econfargs=(
+ --disable-selective-werror
+ )
+
+ econf "${econfargs[@]}"
+}