summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2019-04-17 18:24:05 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-05-09 00:56:14 +0200
commitc90e3bc1f61bac63231b2bd17fcba488e3d36d28 (patch)
tree31762b6e1a92f24528ad64302a596cee355d2379 /x11-misc/xfractint/xfractint-20.04_p14.ebuild
parentx11-misc/xfractint: use HTTPS, fix SRC_URI (diff)
downloadgentoo-c90e3bc1f61bac63231b2bd17fcba488e3d36d28.tar.gz
gentoo-c90e3bc1f61bac63231b2bd17fcba488e3d36d28.tar.bz2
gentoo-c90e3bc1f61bac63231b2bd17fcba488e3d36d28.zip
x11-misc/xfractint: version bump (20.04p14) and EAPI=7
Closes: https://bugs.gentoo.org/683690 Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'x11-misc/xfractint/xfractint-20.04_p14.ebuild')
-rw-r--r--x11-misc/xfractint/xfractint-20.04_p14.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/x11-misc/xfractint/xfractint-20.04_p14.ebuild b/x11-misc/xfractint/xfractint-20.04_p14.ebuild
new file mode 100644
index 000000000000..6b8eb5554039
--- /dev/null
+++ b/x11-misc/xfractint/xfractint-20.04_p14.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+MY_P=${P/_}
+
+DESCRIPTION="A fractal generator"
+HOMEPAGE="https://www.fractint.org"
+SRC_URI="https://www.fractint.org/ftp/current/linux/${MY_P}.tar.gz"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}
+ x11-libs/libXft"
+# x86? ( dev-lang/nasm )"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=( "${FILESDIR}/xfractint-20.04p09-ldflags.patch" )
+
+src_compile() {
+ # Untested, any x86 archteam dev. is allowed to uncomment this.
+ local myasm="foo"
+# use x86 && myasm="/usr/bin/nasm"
+ emake CC="$(tc-getCC)" AS="${myasm}" OPT="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${ED}/usr" STRIP="true" install
+ newenvd "${FILESDIR}"/xfractint.envd 60xfractint
+}
+
+pkg_postinst() {
+ elog "XFractInt requires the FRACTDIR variable to be set in order to start."
+ elog "Please re-login or \`source /etc/profile\` to have this variable set."
+}