summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2021-03-12 18:10:07 +0100
committerSebastian Pipping <sping@gentoo.org>2021-03-12 18:13:52 +0100
commite1151d3c7e9cebd14f2c8b071bf31e4737377808 (patch)
tree7c7b5b58918f6549ad96dac355745add66b3b6a3 /x11-misc/xscreensaver/files
parentapp-dicts/aspell-de-alt: Keyword ~m68k per allarches policy (diff)
downloadgentoo-e1151d3c7e9cebd14f2c8b071bf31e4737377808.tar.gz
gentoo-e1151d3c7e9cebd14f2c8b071bf31e4737377808.tar.bz2
gentoo-e1151d3c7e9cebd14f2c8b071bf31e4737377808.zip
x11-misc/xscreensaver: 5.45
Patches are forward-ports of existing ones Adds systemd support, optfeature, and a few new so-called XScreenSaver "hacks" Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.17, Repoman-3.0.2
Diffstat (limited to 'x11-misc/xscreensaver/files')
-rw-r--r--x11-misc/xscreensaver/files/xscreensaver-5.45-gcc.patch16
-rw-r--r--x11-misc/xscreensaver/files/xscreensaver-5.45-interix.patch32
-rw-r--r--x11-misc/xscreensaver/files/xscreensaver-5.45-remove-libXxf86misc-dep.patch49
3 files changed, 97 insertions, 0 deletions
diff --git a/x11-misc/xscreensaver/files/xscreensaver-5.45-gcc.patch b/x11-misc/xscreensaver/files/xscreensaver-5.45-gcc.patch
new file mode 100644
index 000000000000..b62fd1f309e3
--- /dev/null
+++ b/x11-misc/xscreensaver/files/xscreensaver-5.45-gcc.patch
@@ -0,0 +1,16 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -468,11 +468,11 @@
+
+ AC_DEFUN([AC_CHECK_GCC_ARG],
+ [if test -n "$GCC"; then
+- AC_CACHE_CHECK([whether gcc accepts [$2]],
++ AC_CACHE_CHECK([whether [$CC] accepts [$2]],
+ ac_cv_gcc_accepts_[$1],
+ [rm -rf conftest.$ac_ext
+ touch conftest.$ac_ext
+- if ( ( gcc -c [$2] conftest.$ac_ext -o/dev/null >/dev/null ) 2>&1 | \
++ if ( ( $CC -c [$2] conftest.$ac_ext -o/dev/null >/dev/null ) 2>&1 | \
+ grep unrecognized >/dev/null ); then
+ ac_cv_gcc_accepts_[$1]=no
+ else
diff --git a/x11-misc/xscreensaver/files/xscreensaver-5.45-interix.patch b/x11-misc/xscreensaver/files/xscreensaver-5.45-interix.patch
new file mode 100644
index 000000000000..f9841a49b74a
--- /dev/null
+++ b/x11-misc/xscreensaver/files/xscreensaver-5.45-interix.patch
@@ -0,0 +1,32 @@
+diff --git a/driver/prefs.c b/driver/prefs.c
+index ab97ffa..cc04cc9 100644
+--- a/driver/prefs.c
++++ b/driver/prefs.c
+@@ -969,7 +969,10 @@ write_init_file (Display *dpy,
+ sure that the bits actually land on the disk right away. */
+ /* Update 2020: Apparently here in the future, this sometimes takes
+ 3+ seconds, so let's not. */
++/* Interix has no sync() or alike. */
++#ifndef __INTERIX
+ /* sync(); */
++#endif
+
+ status = 0; /* wrote and renamed successfully! */
+ }
+diff --git a/driver/setuid.c b/driver/setuid.c
+index 3ac78e4..a2b9e15 100644
+--- a/driver/setuid.c
++++ b/driver/setuid.c
+@@ -136,9 +136,12 @@ set_ids_by_number (uid_t uid, gid_t gid, char **message_ret)
+ if (uid == (uid_t) -1) uid = (uid_t) -2;
+
+ errno = 0;
++
++#ifndef __INTERIX
+ if (setgroups_needed_p (gid) &&
+ setgroups (1, &gid) < 0)
+ sgs_errno = errno ? errno : -1;
++#endif
+
+ errno = 0;
+ if (setgid (gid) != 0)
diff --git a/x11-misc/xscreensaver/files/xscreensaver-5.45-remove-libXxf86misc-dep.patch b/x11-misc/xscreensaver/files/xscreensaver-5.45-remove-libXxf86misc-dep.patch
new file mode 100644
index 000000000000..9a2ac62036a9
--- /dev/null
+++ b/x11-misc/xscreensaver/files/xscreensaver-5.45-remove-libXxf86misc-dep.patch
@@ -0,0 +1,49 @@
+libXxf86misc is the client-side code of an X extension that has not been
+supported by the Xserver in more than 10 years. Since xscreensaver's dependency
+on it is automagic, we have to patch configure.in to safely remove it.
+
+https://bugs.gentoo.org/720158
+
+diff -ruN xscreensaver.orig/configure.ac xscreensaver/configure.ac
+--- xscreensaver.orig/configure.ac 2020-05-02 18:09:23.169324761 -0700
++++ xscreensaver/configure.ac 2020-05-02 18:09:52.578233240 -0700
+@@ -104,12 +104,6 @@
+ (It's available if the file /usr/include/X11/extensions/XInput.h
+ exists.)])
+
+-AH_TEMPLATE([HAVE_XF86MISCSETGRABKEYSSTATE],
+- [Define this if you have the XF86MiscSetGrabKeysState function
+- (which allows the Ctrl-Alt-KP_star and Ctrl-Alt-KP_slash key
+- sequences to be temporarily disabled. Sadly, it doesn't affect
+- Ctrl-Alt-BS or Ctrl-Alt-F1.)])
+-
+ AH_TEMPLATE([HAVE_RANDR],
+ [Define this if you have the Resize and Rotate extension.
+ This is standard on sufficiently-recent XFree86 systems, and
+@@ -1888,25 +1882,6 @@
+ fi
+
+
+-###############################################################################
+-#
+-# Check for XF86MiscSetGrabKeysState (but only bother if we are already
+-# using other XF86 stuff.)
+-#
+-###############################################################################
+-
+-have_xf86miscsetgrabkeysstate=no
+-if test "$have_xf86gamma" = yes -o "$have_xf86vmode" = yes; then
+- AC_CHECK_X_LIB(Xxf86misc, XF86MiscSetGrabKeysState,
+- [have_xf86miscsetgrabkeysstate=yes],
+- [true], -lXext -lX11)
+- if test "$have_xf86miscsetgrabkeysstate" = yes ; then
+- SAVER_LIBS="$SAVER_LIBS -lXxf86misc"
+- AC_DEFINE(HAVE_XF86MISCSETGRABKEYSSTATE)
+- fi
+-fi
+-
+-
+ ###############################################################################
+ #
+ # Check for HP XHPDisableReset and XHPEnableReset.
+