summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2024-03-20 23:49:27 -0300
committerPacho Ramos <pacho@gentoo.org>2024-07-15 21:21:45 +0200
commit06042f4b59790dc894bc8ede5df34701eaaaa6cf (patch)
treefdd12831db2f06ac85e88097744fa23a96145329 /x11-misc
parentmail-client/geary: update HOMEPAGE (diff)
downloadgentoo-06042f4b59790dc894bc8ede5df34701eaaaa6cf.tar.gz
gentoo-06042f4b59790dc894bc8ede5df34701eaaaa6cf.tar.bz2
gentoo-06042f4b59790dc894bc8ede5df34701eaaaa6cf.zip
x11-misc/alacarte: Bump to 3.52.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/36866 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/alacarte/Manifest1
-rw-r--r--x11-misc/alacarte/alacarte-3.52.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/x11-misc/alacarte/Manifest b/x11-misc/alacarte/Manifest
index 73e1781dceda..dacbdea47189 100644
--- a/x11-misc/alacarte/Manifest
+++ b/x11-misc/alacarte/Manifest
@@ -1 +1,2 @@
DIST alacarte-3.50.0.tar.xz 255404 BLAKE2B c22aeb83f707e4860c9a84311da2bf87e79db8b8859b8c45d5c1d0f6ead896f15b83cd112ac248fbb83b2bf839afbc90d2a24685c767ebaaaa850dfab8b26d35 SHA512 12578c35e8e68c83b46d81edc59444a92dc672a4a91bb4b443bbc0b26d94a3badf5598602dfc62dfbbabce7e3392c081c39055a201d60d4813b23e061014ee17
+DIST alacarte-3.52.0.tar.xz 255700 BLAKE2B 8a59c5ccd1ba8ee892aee39625ecd56c4cf9500b104f943775bef613a4d8f6ef50cdce1d436a1f2c95268864ab43a72f8e182a2e15f47b3980193c887e91f8c2 SHA512 711166b1d772483be1ca3044f9402ec62dd6bb9c09b71b09944886bac91a72fe9838a60a4cf24649dce33148844b586446c17954129c6bc7aaa3096ba01e1463
diff --git a/x11-misc/alacarte/alacarte-3.52.0.ebuild b/x11-misc/alacarte/alacarte-3.52.0.ebuild
new file mode 100644
index 000000000000..d6f6a3bfb344
--- /dev/null
+++ b/x11-misc/alacarte/alacarte-3.52.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Simple GNOME menu editor"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/alacarte"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep 'dev-python/pygobject:3[${PYTHON_USEDEP}]')
+ >=gnome-base/gnome-menus-3.5.3:3[introspection]
+"
+RDEPEND="${DEPEND}
+ x11-libs/gdk-pixbuf:2[introspection]
+ x11-libs/gtk+:3[introspection]
+"
+BDEPEND="
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_install() {
+ gnome2_src_install
+ python_optimize
+}