summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-17 22:45:41 +0000
committerSam James <sam@gentoo.org>2023-03-17 23:56:12 +0000
commit08d877a77504fcaebc4653dbd4988c6ea9d1bd17 (patch)
tree8499e2c46c597151c438a8d285481a7d41593533 /x11-misc
parentmedia-gfx/gphoto2: fix build w/ clang 16 (diff)
downloadgentoo-08d877a77504fcaebc4653dbd4988c6ea9d1bd17.tar.gz
gentoo-08d877a77504fcaebc4653dbd4988c6ea9d1bd17.tar.bz2
gentoo-08d877a77504fcaebc4653dbd4988c6ea9d1bd17.zip
x11-misc/barrier: fix build w/ gcc 13
Closes: https://bugs.gentoo.org/895088 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/barrier/barrier-2.4.0.ebuild3
-rw-r--r--x11-misc/barrier/files/barrier-2.4.0-gcc-13.patch38
2 files changed, 40 insertions, 1 deletions
diff --git a/x11-misc/barrier/barrier-2.4.0.ebuild b/x11-misc/barrier/barrier-2.4.0.ebuild
index f086465e0601..0c587b0c8a91 100644
--- a/x11-misc/barrier/barrier-2.4.0.ebuild
+++ b/x11-misc/barrier/barrier-2.4.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -43,6 +43,7 @@ DEPEND="
PATCHES=(
"${FILESDIR}"/${P}-includes.patch
+ "${FILESDIR}"/${P}-gcc-13.patch
)
DOCS=(
diff --git a/x11-misc/barrier/files/barrier-2.4.0-gcc-13.patch b/x11-misc/barrier/files/barrier-2.4.0-gcc-13.patch
new file mode 100644
index 000000000000..5b1759049143
--- /dev/null
+++ b/x11-misc/barrier/files/barrier-2.4.0-gcc-13.patch
@@ -0,0 +1,38 @@
+https://bugs.gentoo.org/895088
+https://github.com/debauchee/barrier/pull/1886
+
+From d376d23d534e053a160c32ee1170d237a2f3d6bd Mon Sep 17 00:00:00 2001
+From: "Benjamin A. Beasley" <code@musicinmybrain.net>
+Date: Thu, 26 Jan 2023 09:25:59 -0500
+Subject: [PATCH] Add missing #include directives needed for GCC 13
+
+---
+ src/lib/base/String.h | 1 +
+ src/lib/net/FingerprintData.h | 1 +
+ 2 files changed, 2 insertions(+)
+
+diff --git a/src/lib/base/String.h b/src/lib/base/String.h
+index 9c5a53bac4..fa37f8f0dc 100644
+--- a/src/lib/base/String.h
++++ b/src/lib/base/String.h
+@@ -18,6 +18,7 @@
+
+ #pragma once
+
++#include <cstdint>
+ #include "common/common.h"
+ #include "common/stdstring.h"
+
+diff --git a/src/lib/net/FingerprintData.h b/src/lib/net/FingerprintData.h
+index 938a69538d..522a481353 100644
+--- a/src/lib/net/FingerprintData.h
++++ b/src/lib/net/FingerprintData.h
+@@ -18,6 +18,7 @@
+ #ifndef BARRIER_LIB_NET_FINGERPRINT_DATA_H
+ #define BARRIER_LIB_NET_FINGERPRINT_DATA_H
+
++#include <cstdint>
+ #include <string>
+ #include <vector>
+
+